Support » How-To and Troubleshooting » Unable to locate WordPress Content directory (wp-content).

Unable to locate WordPress Content directory (wp-content).

  • I’m using WP 2.8 and try to upload themes from my admin panel. But it ask me FTP account. I have put my ftp account data and it show this message

    Unable to locate WordPress Content directory (wp-content).

    How can I fix it?

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’ve got the same problem. Just installed WP on my (fresh) site and trying to install a theme it comes up with that same error message.

    I’ve done a quick google of it, some suggesting an edit of the wp-config.php file.

    Either it doesn’t work for me, or I’m not editing it correctly. I’m a newb when it comes to this, so if anyone got any tips I’d be very grateful if it is explained very carefully (spoonfeed within reason).

    These are blogs giving solutions to the problem:


    Being new to both using ftp and to wp/php in general I’m not sure if I’m able to implement those.

    Sorry, no solution here – but I’m running into the same problem – with the same extensive search for solutions. My problem is that I wanted to add ad software, and I got the same messages. My gut says WP might not offer a free theme that is ad-ready. Perhaps that is the free-gimmick. Free blog – no perks.

    Just a hunch.

    Hello everybody!

    Barabas, the first link will solve the problem but in somes hosting’s providers you can’t have more than one account (like ByetHost). I solved it by adding the following code in my wp-config.php:

    if(is_admin()) {
    	add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
    	define( 'FS_CHMOD_DIR', 0751 );

    I’ve just write a post in one of my blogs (a very new blog), but it’s in spanish. May be you will can understand or, at least, be useful. You can see it here:
    Solución a los problemas FTP en WordPress 2.8

    If you have any question, please leave it in my blog 😉 (to respond more faster).

    Sorry for my English :S . I’m copying and pasting this post in part on other threads, sorry again.

    I am running WP in IIS 7. mcarretero’s solution doesn’t work for me. It actually causes a 500 error.

    Any other ideas out there?

    my ftp dir is something like this /domain.com/htdocs
    So I put define(‘FTP_BASE’, /domain.com/htdocs/’); into config file.
    still get Unable to locate WordPress Content directory (wp-content) error,someone know why?


    Thanks man! That trick did the job and I can upgrade my plugins directly (without even needing FTP access). I guess the culprit is file permission or so.

    There is a solution from a user here called “mcarretero” post link is here , his fix was to add this code

    if(is_admin()) {
    	add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
    	define( 'FS_CHMOD_DIR', 0751 );

    to the your wp-config.php file. I had the same problem and this fixed it for me.

    i’m using 2.9.1 and i’m getting this error message.

    these fixes don’t work.

    any suggestions?


    I have WordPress 2.9.2. and all the fixes don’t work.
    I also tried the ftp user.
    It can’t be that difficult i guess.

    I also have wordpress 2.9.2 (and a free Bytehost account) and the previous fixes were not working (rather every page “went blank” (was not loading) and I had to remove the “fix” in order to bring everything back online).
    I solved this problem using the Third Party Host Fix (download, extract, ftp the folder in <wordpress_root>/wp_content/plugins) & activate the plugin).
    This solution worked also with wordpress 2.8.x and different free hosting providers (hyperphp or maybe freehostia, I don’t remember).

    This error occured to me, too. I fixed it by adding two lines:

    putenv('TMPDIR='. ABSPATH .'tmp');
    define('WP_TEMP_DIR', ABSPATH . 'tmp');


    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    near the end of wp-config.php.

    You have to make sure, that you have a tmp directory in your wordpress installation, that is writeable by the server.

    all you have to do is create an ftp account through your cpanel for this option. I created wordpress@mydomain.com. Then set it to ftp to /public_html/wordpress (or where your wordpress directory is). Then use that to install. Worked like a charm!

    This is my first post and I’m pretty new to the whole WP.

    I have installed this to my own *nix NAS box and having this routed from my domain to my home.

    After first installing 2.9.2 I was looking for themes and plugin however there seems to be a general issue with the following error. “Unable to locate WordPress Content directory (wp-content)”

    I’ve tried editing the wp-config.php by adding the following lines at the end:

    putenv('TMPDIR='. ABSPATH .'tmp');
    define('WP_TEMP_DIR', ABSPATH . 'tmp');

    But unfortnately to no avail

    Is there anyone can help. I would very much like to use WP but this is pretty much a “show-stopper” for me at the moment.


    I’ve tried all these fixes on 2.9.2 and on my latest install nothing helps.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Unable to locate WordPress Content directory (wp-content).’ is closed to new replies.