WordPress.org

Ready to get started?Download WordPress

Forums

Aesop Story Engine
[resolved] Unable to load map (6 posts)

  1. jcklngrn
    Member
    Posted 10 months ago #

    Are there any known issues with the custom tiles on ASE 1.0.3 in WordPress v 3.9? I’m getting a blank screen on Chrome v 34.0.1847.116.

    I tried entering 43.503741 and 16.408541 for the latitude and longitude coordinates, but I'm just drawing a blank screen. Here's the input: http://www.brooklynabroad.com/wp-content/uploads/2014/04/Screen-shot-2014-04-19-at-8.02.30-PM.png and here's the output: http://www.brooklynabroad.com/wp-content/uploads/2014/04/Screen-shot-2014-04-19-at-8.04.02-PM.png

    The error that I get from the console shows: "Uncaught TypeError: Cannot read property ‘lat’ of null" for Leaflet.

    Note that I'm also using my own (free) Mapbox account. Any ideas for troubleshooting steps? Thanks!

    https://wordpress.org/plugins/aesop-story-engine/

  2. Nick Haskins
    Member
    Plugin Author

    Posted 10 months ago #

    Do you have a link to the page where the map is at? Also,can you paste in your map tile ID here so I can test?

    To answer your question ASE has been compliant with 3.9 for the last 2 months or so (we like to be prepared)

  3. jcklngrn
    Member
    Posted 10 months ago #

    Yup. Here you go, Nick! Just published it as a test.
    http://www.brooklynabroad.com/pomodoro-breaks-were-never-this-good

    Here's the MapBox MapID: jcklngrn.i16ibof2

  4. Nick Haskins
    Member
    Plugin Author

    Posted 10 months ago #

    OK i see what's going on. Try adding a "starting location." This option field is in that same area. Try adding this as the starting view.

    43.50,16.41

    Let me know how you go about once adding this.

  5. jcklngrn
    Member
    Posted 10 months ago #

    Fantastic! I didn't realize it was required (although, now I feel like an idiot haha) - thank you for the help!

  6. Nick Haskins
    Member
    Plugin Author

    Posted 10 months ago #

    Awesome! I'll work on a better way to make this not happen in the future. Possibly default to the first marker that you enter if no starting coordinate is filled out. Glad to hear its fixed and apologies for the inconvenience.

Reply

You must log in to post.

About this Plugin

About this Topic