WordPress.org

Forums

[resolved] Unable to install WP to it's own directory - files not found (7 posts)

  1. Mandelion
    Member
    Posted 8 years ago #

    I installed WP to it's on directory on my domain (http://www.mandelion.com/blog) and am trying to set up the options so when you hit Mandelion.com the blog loads.

    I have followed all the steps listed in the document about putting WP in it's own directory with no success. I was able to change the options in the WP admin panel and changed the index.php file in the root directory to the proper setup. But I noticed there is no htacess file in any of my directories for me to copy. Not in the blog folder, where the installation originally went, and not in my root directory. I want to have the blog in a seperate directory to keep my domain organized.

    Can anyone here help me out so I can finally get my blog online? It would be so greatly appreciated.

    Thanks!
    Mandy

  2. moshu
    Member
    Posted 8 years ago #

    If your permalinks are NOT set to be "nice" you don't need any htaccess.
    Also, read the instructions again: you need the index file BOTH in root and in the WP directory. The instructions say: copy (not move!).

  3. Mandelion
    Member
    Posted 8 years ago #

    Sorry for that but I did copy, not move. I have it uploaded to both sections with the same copy of the file once I updated the information inside the file and still have had no success.

    thanks for any help.

  4. moshu
    Member
    Posted 8 years ago #

    Well, I might be misreading your post above, but:
    1. in the WP directory you do not change anything in the index
    2. you modify the path to the blogheader in the index file located at the root.

  5. Mandelion
    Member
    Posted 8 years ago #

    it was my mistake - I apologize. I've been working on this all night and typed that in wrong.

    I saved a copy of the index.php file to my drive. I modified it with the correct info to read:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./blog/wp-blog-header.php');
    ?>

    then I uploaded it to the root and /blog directory again, overwriting what was there in the blog folder with the index.php file. I verified that the index.php file is in both locations and is the version above then made sure in options I have this set in:

    WordPress URL: http://www.mandelion.com/blog
    Blog Address: http://www.mandelion.com

    I'm sure it's something so easy I'll feel like a dork for not seeing it. :)

    Thanks so much for taking the time to help me out. I am a first time user (there are no entries to my blog or anything) and am LOVING it so far after using Expression Engine for 5 years now.

    My blog is here: http://www.mandelion.com/blog and my domain root is the http://www.mandelion.com .

    thank you so much again!

  6. moshu
    Member
    Posted 8 years ago #

    then I uploaded it to the root and /blog directory again,

    Please, read my post above again! That's exactly the problem.

    Also, your blog is there:
    http://www.mandelion.com/index.php
    (just remove the index.html!)

  7. Mandelion
    Member
    Posted 8 years ago #

    Thanks - I totally forgot about my index.htm file. It's up and running.

    Thanks again for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic