Support » Fixing WordPress » unable to install premium themes (Are you sure you want to do this?)

  • Hello,

    I have been having some issues with a new install of wordpress for a new website. I bought a new domain via and ran their WordPress scripts to install WordPress. I initially installed WordPress 3.0.1 Beta. After the initial installation i did not install ANYTHING else at all…no plugins, no widgets, no nothing. next step was I bought a $27 theme from and attempted to install the .ZIP file thought the automated ‘install theme’ prompt in WordPress. When doing this it took FOREVER to upload, and after a while the upload of the theme timed out and I got the following ‘error message’:

    Are you sure you want to do that?

    Try again?

    I have had no other issues with any of my other blogs that have been running wordpress 3.0.1…i have 6 other blogs running lots of plug ins and widgets and hacks and i’ve had no problem at all. but i thought i’d troubleshoot it anyway. so i totally deleted the wordpress version on that server, then re-installed wordpress using version 2.9.2 which was the most current stable version. I then installed the theme once more via the .ZIP automated upload process, still got the exact same message. At this point i thought it must have been a faulty theme and tried another premium theme i paid $55 and i was getting the exact same issue!

    I have done some Google searching, and read some previous threads on this forum, however they don’t seem to directly address my specific issue. I can’t upload any other themes!! I can not tell you how amazingly frustrating this is, especially paying all this money for premium themes and not being able to use them!

    Again, a brief overview of what i did to troubleshoot to help you on in helping me:

    *Originally ran 3.01. Beta, didn’t work
    *Un-Installed 3.0.1
    *Re-Installed with 2.9.2
    *Tried alternative Theme
    *Attempted to Manually FTP theme (didn’t work)
    *Did not install any plug-ins or widgets (so nothing should have interfered with the install, it was a fresh install)

    Please, any help would be MUCH appreciated, i have lots of clients asking questions as to why there blog is not up and i’m running short on things to tell them, i’m really in a bind…

    Please assist

    if anyone wants to contact me directly on this issue, please e-mail me directly at:


Viewing 7 replies - 1 through 7 (of 7 total)
  • Make sure the theme(s) you are using are both known compatible with 2.9.2. Also try increasing your max_execution_time, your max_input_time, and your memory_limit, via the php.ini. If you do not have a php.ini file, use the PHP Config icon in the cPanel to install one. Also set your php mode to Single php.ini while you are there.

    Maybe try something like:
    max_execution_time = 120
    max_input_time = 120
    memory_limit = 64M

    I am also having this problem with premium themes from themeforest. however, my theme clearly states that it is compatible with 2.9. As for 2.9.2, I do not know.

    I’m unfamiliar with the above steps to solve, but I will give it a try. Perhaps a little more detail would help? the cPanel access through WordPress or my host? I just need a little bit more clarity here to give it a shot.

    jill5455: Depending on your host, the methods as to how to edit these settings may be different. You may need to check with your host to see if you have the ability to edit your php.ini and how that would be done.

    It could also be to a failure in downloading, or uploading the theme. Re-download the theme to make sure the all the files, etc., are properly obtained, then re upload it again. If you still have issues, the theme may be incompatible.

    I am having the exact same issue as OP but I can’t change my theme files quickly as the backend work is done by our host, and I can’t get a hold of them right now…

    Any simple ways to clear this up?

    I would do what bh_WP_fan recommended.

    But also increase the
    ; Maximum size of POST data that PHP will accept.
    post_max_size = 10M

    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 10M

    to a value larger than your theme file.

    I am so stessed for 6 days i have tried to do the same thing. My premium templates are from http://www.templatesold and my hosting is Go Daddy.

    Contacted Godaddy and they walked me through the process of installing – confirmed i was doing it right

    there is not a number for templatesold to ask them what the problem is and

    Word press only has this blog.

    Extremely frustrated

    If someone comes up with an answer please email directly at

    You should try uploading your theme via FTP to the /wp-content/themes directory.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘unable to install premium themes (Are you sure you want to do this?)’ is closed to new replies.