• Resolved davewinfield

    (@davewinfield)


    Hi Sayontan, hope you are well and staying safe.

    I am struggling with a site that will not obtain a token from Google.

    I have tried :

    • Disabling all plugins except Photonic and cloudflare
    • Created a new Token
    • Disabled caching on CLoudflare (Dev Mode)
    • changed from php7.4 to php7.1 on the server
    • Tried your workaround with the playground, which tells me there is a URL mismatch (old and new tokens)

    No matter what I do, I just get three cycling squares, which never go away. No timeouts, no error messages, just spinning forever.

    Can you think of anything else I could try please?

    Regards,
    Dave

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Sayontan

    (@sayontan)

    This is weird.

    Try this:

    1. Go to the file wp-content/plugins/photonic/includes/scripts/admin/helpers.js, line 58. You can get to it from your WP dashboard, via Plugins → Plugin Editor.
    2. You will see this:
      Photonic_Admin_JS.obtain_token === undefined ? 'Step 2: Obtain Token' : Photonic_Admin_JS.obtain_token +
    3. Change it to:
      (Photonic_Admin_JS.obtain_token === undefined ? 'Step 2: Obtain Token' : Photonic_Admin_JS.obtain_token) +
      Basically put parentheses around the expression, but make sure that the + stays outside the brackets.
    4. Save the file and retry the authentication.

    This seems to have broken with the WP 5.5 update, but I cannot see why that would happen.

    Hi Sayontan!

    Thank you for the immediate response, and I am delighted to say that your suggestion resolved the issue!

    Just a note for anyone else reading this, for me the path was slightly different than you suggested for some reason, my helpers.js file was at :

    wp-content/plugins/photonic/include/scripts/admin/helpers.js

    Have a great day, and thanks once again for your brilliant product and top-notch support!

    Cheers,
    Dave

    Plugin Author Sayontan

    (@sayontan)

    Just a note for anyone else reading this, for me the path was slightly different than you suggested for some reason, my helpers.js file was at :

    wp-content/plugins/photonic/include/scripts/admin/helpers.js

    I had written the same thing… the browser’s hyphenation rules put “wp-” and “content” in different lines 🙂

    SJF

    (@sjf)

    @sayontan – this fix solved an issue that’s been driving me crazy all morning. Could you please apply this fix in an update so it’s compatible with 5.5.0+ (I’m on 5.5.1 and this fixed it, too) Thanks!

    Solved, thanks for all !! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.