Support » Plugin: Google Analytics » Unable to get local issuer certificate (v2.0.3)

  • I have been getting this error while trying to autenticate with Google since v2.0.0. The new 2.0.3 still gives the error but as a notice at the top of the screen instead of a pop up message.

    After I enter the key from the Google authentication dialog, I get this error.

    [Ga_Lib_Api_Client_Exception] SSL certificate problem: unable to get local issuer certificate (60)

    I am running WordPress 4.7 on a Microsoft Azure website. The site is http not https so I’m not sure what local certificate it’s looking for.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have tried everything I can thing of to get 2.0.3 to authenticate with Google. Nothing positive happens when I press the authenticate button. What does an access key from google look like. Is it the UA-12345678-1, or is it the 12345678? I’ve tried them all, and nothing works. I am deactivating the plugin and going back to doing it the “hard” way.

    Hi @alashcraft,

    Thanks for letting us know, we’re still investigating this matter and hope to release a fix revolved around better authentication. I’ve let our engineering team know of the error code you’ve received, I’ll be sure to follow up once we know more.

    Hi @steve13565,

    The access key is provided once you authenticate via Google. You should receive a pop up once you allow permission via Google.

    First box would look like this: https://cl.ly/iMq2
    Second box is this: https://cl.ly/iNaz

    Our release for 2.0.4 will have these features sorted out, I’ll be sure to let you know once we launch an update.

    Sorry again for the inconvenience guys.

    Oh, I have pop-ups disabled. Maybe there was a warning that I just did not notice.

    With v2.0.4 I get a more generic error now after entering the key from the Google auth process:

    “There was a problem with Google Oauth2 authentication process.”

    Same error in v2.0.5 that I had in 2.0.4:

    “There was a problem with the Google Oauth2 authentication process.”

    Plugin Author ShareThis

    (@sharethis)

    Hi @alashcraft we tried to replicate it but couldn’t find the reason. Could you send a screenshot with the console open when trying to authenticate. You can do it this way in chrome https://cl.ly/3t2a42453Q3h

    Or if you just want us to debug it, could you email the temporary access and dev team can go in to see the issue. If you’re interested please send us an email with the account/password here: support@googleanalytics.zendesk.com

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Unable to get local issuer certificate (v2.0.3)’ is closed to new replies.