WordPress.org

Support

Support » Plugins and Hacks » WP Document Revisions » Unable to find/view 'Documents' Menu item in WordPress Admin UI?

Unable to find/view 'Documents' Menu item in WordPress Admin UI?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Strange. Would it be possible to get a run down of what sort of plugins you’re currently using (what theme as well)?

    Is it not showing up for certain kinds of users or not showing up for everybody (ie: can a user with the role ‘Admin’ see it, but not one with the role ‘Subscriber’)?

    Hi Cojennin, many thanks for your response.

    It is not showing up for me (Administrator / account/server owner). I have not as yet tried any other user role.

    The Theme is ‘Alterna,’ by ActiveToFocus (ThemeForest).

    I am happy to provide you with a list of all plugins if necessary, however I have actually tried deactivating them all and ‘Documents’ still did not appear in the WP Admin UI.

    Regards,

    Mike

    Ooph. Premium theme. Makes it a bit more difficult to fix, but hopefully not impossible. If you’ve disabled all the plugins and it still isn’t showing up, chances are pretty good that it might be the Alterna theme.

    First thing you could try is going directly to the url of the page, which would be http://url of your site/wp-admin/edit.php?post_type=document

    (Need to be logged in to do the above. http://url of your site/wp-admin/edit.php is the url you use to access your posts from the admin side, by adding the “?post_type=document” you’re requesting that it show you the “Documents” screen instead of the “Posts” screen.)

    So just plug that url (substitute the “url of your site” with the actual url of your site). With any luck, the conflict is purely a superficial one, and the post type exists but Alterna is preventing the actual sidebar link from being shown.

    If that works, then maybe check around the Alterna admin for adding or removing menu items from the admin sidebar? Might be that they have in place some option which prevents menu items from being shown or displayed.

    If you can access the “Documents” page but you can’t find said option, there’s two possible courses of action. The first would be to try changing the location of the “Documents” link and see if it’ll show up. This can be accomplished by pasting something like the following code into the functions.php file of your theme (hopefully it has one).

    add_filter( 'document_revisions_cpt', 'change_document_menu_location', 10, 1);
    
    function change_document_menu_location( $args ) {
     	$args['menu_position'] = 5;
    	return $args;
    }

    Try modifying the “5” to any of the numbers located here, underneath the “menu_position” section.

    The other option you can try is opening up a support ticket with Active Focus to see if they know what’s going on, or have some sort of simple solution or trick to trigger showing menu items that have been registered by another plugin.

    Hopefully this helps, feel free to post back here if you have any more questions or concerns. If you do open a ticket, feel free to post the link and maybe I can +1 it or something along those lines to get it moving along.

    Dear Cojennin,

    I did as you asked and attempted to access the plugin via manual entry of the url:

    http://(mydomain).com/wp-admin/edit.php?post_type=document

    Unfortunately I was unable to access anything, receiving the well-documented error screen ‘Cheatin’ Uh?’

    After Googling this error for I bit it seems it is related to a access permissions error? As I am the Administrator, I don’t know how this can be…?

    Hence, on a hunch (after reading your forums), I looked in my db to see if I have at any stage had User Access Control plugin installed. It seems that I did a long time ago, but no longer use it.

    Do you have any recommendations as to how to resolve the issue?
    Should I reinstall User Access Control?

    Regards, Mike

    Righteous. Nice work snoopin that out. Not sure I know that plugin (is it this one?) but reinstalling it and tweaking around might do the trick.

    I’m having this exact same issue. I have yet to be able to figure out what the issue is. I’ve tried turning off and on all plugins I’ve tried switching themes over to twenty ten. I’ve tried doing the above. I can get to the “/edit-tags.php?taxonomy=workflow_state&post_type=document” but heading to “/edit.php?post_type=document” results in the “cheatin huh?”. Basically its exactly the same symptoms at the above without ever installing the roles plugin. It’s a relatively fresh install of wordpress as well currently in development.

    Any Thoughts would be remarkably helpful.

    Thanks!

    I am having the same problem. No Documents item on the Admin nav. Any insight on how to fix would be great!

    Thanks,
    Myra

    Creating a new user fixed this issue for me; I then logged in as that user (lo and behold the Documents menu item appeared) and deleted the problem user, assigning their posts to the new user.

    I experienced the missing Documents menu item issue after evaluating Members and Role Scoper plugins to adjust the capabilities assigned to a (non-Administrator) role, however in my case the symptoms were not obvious initially.

    I deactivated Members and Role Scoper plugins after evaluating them; the Documents menu remained active, but deactivating and reactivating the WP Document Revisions plugin triggered the disappearing Documents menu bug for me.

    @davidhealy You sir are a gentleman and a scholar.

    MI C

    @mi-computsolutions

    So what is the fix for this issue as there are lots of people (including but not restricted to @ThomasBartel-5 months unresolved, @kuba Mikita-7months unresolved) having the same problems on their WordPress install. It is clear that we will have to create custom user role on our portals at some point. In the case of a member based INTRANET site, I don’t think it will be expected to recreate all users every time this happens.

    What exactly is the way forward from here? @cojennin

    As administrator, when you check the view post button, you should be able to view what is posted without question. When you post a document, it should post. I haven’t been able to view my post or edit them or work with my own site at all. If the administrator cant work it, how is a visitor supposed to?
    The best solution I can figure is to find a better place to post the documents you want to. my site is forem-forwe.com. Maybe somebody else can read my posts, I don’t know. I think an outfit that specializes in having a site designed to publish information should have the proper tools and easy instructions for someone who has never done this before. Why should the customers have to figure out how to run this outfit? I don’t get it.
    It is impossible to get in here, get in your own site, develop it, or to get answers. I am just about fed up with the whole thing. If I cant get an answer that works, and is simple to apply, I will find something that does. I think Microsoft or IE or somebody should know how to do it. These people wont even give you any directions. None. No. Nothing. None.

    I too have this specific issue. The Documents menu is not showing on the Admin Navigation Pane. I tried with different themes (even default wp themes), disabling plugins, using the direct url as stated in above comments, changing user levels, different user levels, creating new users, etc. I updated the wp installation, re installed the plugin.
    But didn’t succeed.
    What maybe the problem???

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Unable to find/view 'Documents' Menu item in WordPress Admin UI?’ is closed to new replies.
Skip to toolbar