Support » Plugin: Regenerate Thumbnails » Unable to fetch a list of attachment IDs

  • Resolved NicheLabs

    (@allennichelabs)


    Unable to fetch a list of attachment IDs to process from the WordPress REST API. You can check your browser’s console for details.

    WordPress 4.9.6
    Regenerate Thumbnails 3.0.2

    I have thousands of images and it does run for awhile but always stops at after 5800.

    Here is the browser’s console details:

    Regenerate Thumbnails: Error while trying to regenerate attachment ID 14497
    Object { readyState: 0, getResponseHeader: getResponseHeader()
    , getAllResponseHeaders: getAllResponseHeaders(), setRequestHeader: setRequestHeader(), overrideMimeType: overrideMimeType(), statusCode: statusCode(), abort: abort(), state: state(), always: always(), then: then()
    , … }
    error build.js:1:11044
    Regenerate Thumbnails: Error while trying to regenerate attachment ID 32245
    Object { readyState: 0, getResponseHeader: getResponseHeader()
    , getAllResponseHeaders: getAllResponseHeaders(), setRequestHeader: setRequestHeader(), overrideMimeType: overrideMimeType(), statusCode: statusCode(), abort: abort(), state: state(), always: always(), then: then()
    , … }
    error build.js:1:11044
    Regenerate Thumbnails: Error getting a chunk of thumbnail IDs to process.
    Object { readyState: 4, getResponseHeader: getResponseHeader()
    , getAllResponseHeaders: getAllResponseHeaders(), setRequestHeader: setRequestHeader(), overrideMimeType: overrideMimeType(), statusCode: statusCode(), abort: abort(), state: state(), always: always(), then: then()
    , … }
    error Forbidden build.js:1:9457
    Regenerate Thumbnails: Error getting a chunk of thumbnail IDs to process.
    Object { readyState: 4, getResponseHeader: getResponseHeader()
    , getAllResponseHeaders: getAllResponseHeaders(), setRequestHeader: setRequestHeader(), overrideMimeType: overrideMimeType(), statusCode: statusCode(), abort: abort(), state: state(), always: always(), then: then()
    , … }
    error Forbidden build.js:1:9457
    Regenerate Thumbnails: Error getting a chunk of thumbnail IDs to process.
    Object { readyState: 4, getResponseHeader: getResponseHeader()
    , getAllResponseHeaders: getAllResponseHeaders(), setRequestHeader: setRequestHeader(), overrideMimeType: overrideMimeType(), statusCode: statusCode(), abort: abort(), state: state(), always: always(), then: then()
    , … }
    error Forbidden

Viewing 3 replies - 1 through 3 (of 3 total)
  • NicheLabs

    (@allennichelabs)

    I went ahead and installed WP-CLI and am currently running this from the command line and so far it is chugging right along. It is currently at 19500 of 333324 images. Hopefully this has resolved the issue. It definitely runs a lot faster.

    I’m going to assume it had something to do with the amount of images, the amount of resources, or the amount of time being used to do this, or all of the above.

    this is an artifact of upgrading to WP 4.7.

    The WP-CLI commant is NOT identical to this plugin but “similar”. The image sizes might differ depending to the plugins loaded and the theme. As long as it works for you, that’s great!

    Still: the plugin is broken since WP 4.7

    I’m experiencing this issue as well. WP-CLI wp media regenerate --yes seems to work. Is there no patch for this yet though?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Unable to fetch a list of attachment IDs’ is closed to new replies.