WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-to-lead for Salesforce CRM
[resolved] Unable to enter value of 0 for Number field (3 posts)

  1. seasaltweb
    Member
    Posted 6 months ago #

    hello. Thanks for a great plugin. I have a couple of issues I need your help with please.
    1. I have a text field for users to enter information (number of mobile phones business has). If they enter 0 which is a valid entry, it keeps returning the error message - this field is required.
    Can you please let me know how to allow 0 as an entry? In SF the value of 0 is able to be entered. The custom field is defined as Number(18, 0) (I am new to SF and have been provided the field details from the client)

    2. The links to the SF form are on the home page, however when clicked they take forever to load (if at all). I do have Wp Super cache installed and didnt know if i should have caching turned off for the form page. Can you please advise?

    The site is in maintenance mode, however if you need it off to help solve these problems, please let me know and Ill turn it off quickly. Thanks!
    My form is on the page http://www.broadland.com.au/voucher
    - Sheridan

    https://wordpress.org/plugins/salesforce-wordpress-to-lead/

  2. Nick Ciske
    Member
    Plugin Author

    Posted 6 months ago #

    1. Yeah, PHP treats 0 as false, so I can see why that would happen. You could use a validation filter on that field to change the validation result to true if it's "0" ... but "0" should probably be a valid entry for a text field. I should have a fix in the next release.

    2. If you have the catpcha enabled the plugin tells super cache to not cache the page (as that breaks the captcha image). I can say it's not the plugin slowing down that page (it's a pretty slim little plugin) ... so I'd suggest you figure out why your site is slow without caching... a cache friendly captcha is on the todo list (release TBD).

  3. Nick Ciske
    Member
    Plugin Author

    Posted 6 months ago #

    1. Fixed in 2.4.2. Plugin now checks strlen vs using a boolean check. Should fix your issue.

Reply

You must log in to post.

About this Plugin

About this Topic