Support » Fixing WordPress » Unable to enter the admin panel – Too many redirects after changing URL

  • Resolved miquelmor

    (@miquelmor)


    Hello,

    I recently obtained the free SSL from Cloudflare and despite setting up the rules, going through with the DNS changes, and automatic HTTPS rewrites for mixed content my website would still not use https.

    Then I did a newbie mistake, in the Settings->General panel I changed both addresses to https://www.dataandfinance.com. This of course created the loop error, which causes too many redirects. The problem is that now I’m locked out since my wp-admin page presents the too many redirects error. I’ve disabled the rules and automatic HTTPS rewrites but I still can’t access my WordPress panel to change the addresses back. What’s weird is that even though I changed both the dataandfinance.com doesn’t get stuck in a loop.

    1. How can I log in if the wp-admin page is not working? I’ve even gone ahead and disabled the SSL completely in Cloudflare and still nothing.

    2. Once I’m able to log in to WordPress what should be the correct settings? I’ve read that the Site URL in settings in the WordPress panel should be changed to https but others say to don’t touch it at all.

    Thank you for your help!

    • This topic was modified 6 months, 2 weeks ago by miquelmor.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Depending on your host you may need to get an SSL installed on the hosts end. I had similar problems a few weeks back with a clients site which was hosting by a widely used and well known hows only to find out that the cloudflare SSL we’d activated was useless because of the hosting providers server configuration requiring the SSL be implemented on their side not cloudflare’s.

    You may need to roll back to the SSL-less backup to get the site loading correctly and then contact your hosting provider to get an SSL implemented on their end.

    Hope this helps get you going in the right direction. Once you find a solution please tag the thread as completed.

    @miquelmor To add to @binarywc response you could log into your hosting and navigate to the phpmyadmin and find wp_options (wp could be something else) and change line 1 and 2 (siteurl & home option name) to not have the https.

    Stef

    (@serafinnyc)

    If you have ftp access you could add this snippet to config with the old urls.

    define( 'WP_HOME', 'http://example.com' );
    define( 'WP_SITEURL', 'http://example.com' );

    I was able to fix the issue by going with @jmeyer2485 recommendation and changing the lines 1 and 2 in wp_options.

    Thank you all for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unable to enter the admin panel – Too many redirects after changing URL’ is closed to new replies.