Support » Plugin: s2Member Framework (Member Roles, Capabilities, Membership, PayPal Members) » Unable to edit user password in users profile

  • Resolved ted_smith



    I am using s2Member 140105 and WP 3.8.1.

    My problem is that when I click on Dashboard –> Users –> Edit (to edit a user profile) the “Password” field is not there and hasn’t been since I was using WP 3.6.X.

    So I cannot reset passwords.

    I’m not sure if it’s another plugin that might be blocking this (if you know of one that does please let me know?) but I wanted to check if this is something that s2Member might have changed and if so, where would I look to revert it so that I can edit user passwords. I cannot even edit my own password!

    Screenshot :

Viewing 8 replies - 1 through 8 (of 8 total)
  • PS…I tried changing ‘Redirect members away from the default profile panel?’ from “Yes” to “No” in the ‘Member Profile Modifications’ section, but the password reset fields still do not show at the bottom of my edit profile page. Instead there are various s2Member fields, none of which are a password reset.

    Did you check further down? In my dashboard, the password is below the Bibliographical info. Your image does not show below that.

    Yes. Sorry for the screenshot – I rushed it. But yes, I did try the whole page. :

    As per the post above that clearly shows s2Member fields in place of where the password reset should be (just below bio field), can anyone suggest what might have happened here, or at least eliminate s2Member as the problem? If I disable the plugin temporarily, will I be able to just re-activate it, or does the encryption key and all those things mean my site will stop if I do that?

    I have two websites, both use the same version of WP.

    I have downloaded /wp-admin/new-user.php from both websites and their hashes are exactly the same, yet the “Add new user” via WP control panel looks different.

    Both sites use the same theme, too, which is the professional theme “Awake v3.0”.

    I have attached screenshots of both. As you can see, one shows the addition of a password, and one does not.

    SiteA :
    SiteB :

    So not only can I not edit the password of an existing user, I cannot create a new one, either. If I try I get an error that I have not set a password, even though there is no password field.

    Surely this has to be to do with some setting of S2Member, somewhere?

    If I scared to disable s”Member, though, because of the encryption key that is set.

    I am not specialist but have you tried temporarily changing the theme to the default JUST to see if it would work? Just in case it is something s2M does not like about the theme itself?

    I haven’t, but I dare not do so. I have disabled it before and then re-enabled it and all the settings I had applied (sliders, footers etc) were all reset to default values so I had to spend ages setting it back up again.

    Note also I have updated it to Awake 3.4 and the problem persists 🙁

    Turned out it is BPS Security (BulletProof Security plugin).

    BPS Security –> Login Security –> Enable password reset. I had set it to not allow it! SOLVED

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Unable to edit user password in users profile’ is closed to new replies.