Support » Fixing WordPress » Unable to edit themes after 4.9 or 4.9.1

  • All of my 20+ sites, each with different plugin/theme configs, all existing on the same server stopped being able to update theme files after the WordPress core update to 4.9 or 4.9.1 – I think 4.9

    the error:

    ‘Something went wrong. Your change may not have been saved. Please try again. There is also a chance that you may need to manually fix and upload the file over FTP.’

    It is worth noting that I was able to edit the themes before the update.

    • This topic was modified 1 year, 9 months ago by  robotor.
Viewing 6 replies - 16 through 21 (of 21 total)
  • I have the same issue. When I Deactivate ‘Calculated Fields Form’ (currently Version 1.0.208) plugin I am able to edit themes.

    • This reply was modified 1 year, 7 months ago by  madhuka.
    • This reply was modified 1 year, 7 months ago by  madhuka.

    Same issue — trying to edit header.php (and other files, such as CSS, etc.) using the WP editor and I get the same error. What’s up WordPress team? This seems to be a common issue after the 4.9 update… :/

    This is so idiotic. I cannot edit my site’s php. I currently am in a spot where I can’t FTP to the server either. Amazing new feature!

    Still not able to edit. I’m using a vanilla install, no plugins active, 2017 theme, no theme amends etc.

    http://epdevsite.co.uk

    I have the same issue across many servers on different hosts so I’m pretty underwhelmed by this.

    derrickr

    (@derrickr)

    I finally found a fix, that works for me and perhaps might for you.

    Basically, 4.9 onwards requires loopback to the server. This is required to ensure any code changes don’t break the site. i.e. if WP determines that a code change is deemed to break the site, WP will revert back to the previous version of the changed code, thus not allowing broken code on the site, to ensure it keeps running (thinking: better an old working site, than a new broken attempt). However, if WP can’t communicate back to the site (via loopback) it won’t be able to preform the code check and hence won’t allow code updates.

    FYI, my approach was as follows:
    1. Using the healthcheck troubleshooter I received this error message:

    “The loopback request to your site failed, this may prevent WP_Cron from working, along with theme and plugin editors.<br>Error encountered: (0) cURL error 6: Could not resolve host: myHostName.com”

    2. A quick google, to enable server loopback requests, led me to: https://www.digitalocean.com/community/questions/how-do-i-enable-loopback-connections-on-ubuntu-14-04

    Which had determined there was an issue with the ‘/etc/hosts’ file!

    3. I then simply added my domain to the localhost (127.0.0.1) and I no longer get the errors!

    e.g. 127.0.0.1 myHostName.com

    Unfortunately, I’m not sure how to apply this fix to shared hosting (maybe ask the hosting admins?), but if you’re on a VPS this might work for you.

    Hope this helps someone

    Scott

    (@magius72)

    Thanks for your reply @derrickr!

    Unfortunately, yes, am on shared hosting, so that won’t work in my case. Hope it helps others though!

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘Unable to edit themes after 4.9 or 4.9.1’ is closed to new replies.