Support » Fixing WordPress » Unable to edit theme in editor after WordPress 4.9 Update

  • My hosting service provider recently updated my WordPress to 4.9.

    After that, I’m receiving error whenever I try to edit any file in the Appearance -> Editor section.

    The error it gives is: Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.

    OR

    “Scrape Nonce Failed”.

    Please let me know if there’s a solution to it as I feel that the real issue is with the new version of WordPress because I’ve seen the same error with other users after they upgraded to 4.9.

    Someone said that a plugin will resolve the issue but I want to keep the plugins at minimum.

    Looking for the resolution ASAP.

    Thanks,
    Saad.

Viewing 4 replies - 16 through 19 (of 19 total)
  • @w2owebmaster Please see the note from the moderator above:

    Deactivate the plugin, which you’ve already done.

    Inform the plugin developer.

    Create a new thread so that proper log of that plugin is kept.

    Let the plugin developer know about that thread.

    We received your ticket on our pods.io/forum/ but I think they were advising that the thread should be on the WordPress.org forum.

    I hate to tell you this, but we’ve worked with several people who had this issue and every single time, it had to do with either their theme code or with their hosting environment. The HealthCheck plugin (and the WP Editor change) isn’t giving enough informative details for anyone to actually track down the problem. It’s just pointing at plugin authors as the problem, which is not a solution.

    One of our plugin contributing developers even provided a fix to the WP Editor to at least provide back the error to the user instead of just saying ‘we can’t edit your theme files’. Here’s that ticket from 12 days ago:
    https://core.trac.wordpress.org/ticket/42773

    We’re happy to help you try to figure out where in your theme or hosting environment the problem might be, but we are a free plugin with free support and extremely limited resources. The issue continues to be not providing enough of an error message to actually identify the problem.

    You’re welcome to jump on our Slack Chat at https://pods.io/chat/ though it is after hours so I won’t be able to help you until tomorrow morning.

    • This reply was modified 2 years, 9 months ago by Jim True.

    For my site it was the plugin “Photo Gallery” Version 1.4.4 | By Photo Gallery Team, for anyone interested in knowing.

    Currently experiencing the same issue. I’ve deactivated all plugins and reverted to the default Twenty Seventeen theme, and I’m still unable to edit my functions.php file (getting “Scrape Nonce Failed” error).

    The only workaround I’ve found is editing my main theme while having a different theme activated. For some reason I’m unable to update functions.php in the currently active theme.

    Has there been any progress in resolving this issue?

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    @scribblescratch, if you need support then per the forum welcome please create your own new forum post. Thanks.

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Unable to edit theme in editor after WordPress 4.9 Update’ is closed to new replies.