WordPress.org

Support

Support » Plugins and Hacks » Unable to edit settings

Unable to edit settings

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Shareaholic

    @shareaholic

    Hi @didier77, when you click on “edit” does anything at all happen? A settings modal is supposed to come up. Are there any errors in the console?

    Same problem here, nothing at all comes up when hitting edit.

    Unfortunately my firefox is in Danish, so console reports in Danish aswell, but tried translating best I could:

    http://pastebin.com/PLLFjY1v

    That got truncated by Google translate, I made a logfile if it is worth anything

    http://boris-el.dk/wp-content/uploads/2013/07/log.txt

    from first page load to first clicking edit.

    @ramshackles

    Thank you for providing the log. I’ve directed it to one of our engineers, and he took a look and will be investigating further tomorrow. Your patience is greatly appreciated as we try to isolate this issue.

    A few things to try for both you and @didier77 as well (this may sound silly and not apply to your situation, but please see if it helps in any way):

    • Check that you have JavaScript and Cookies enabled in your browser settings.
    • Disable any browser extensions that could be interfering with this functionality (such as Ghostery).
    • And clear your browser’s cache before refreshing the plugin settings panel.

    @Shareolic,

    Sorry for the delay to answer. What did you mean by “setting modal is supposed to come up”? Is there a modal dialog box? I don’t have received any warning from my browser that a dialog box is blocked? As you probably know, most of users disable pop-up…

    Unfortunately, I cannot send you console logs as I have revert back to version 6.

    After reading some comments/answer on version 7, it seems that it is know necessary to have a shareolic account to use the sexybookmark plug-in. Did you confirm?

    Thanks,
    Didier77

    Hi there people. I had the same issue and I can confirm that it will be get solved after clearing the browser cache. I am using Google Chrome.
    Thanks!

    I’m sorry guy’s this is a bit of a disaster. 7.0.2.0 doesn’t fix the issues. On an iPAD or iPhone the buttons don’t show on my posts (its a responsive design based on MAx Magazine – a standard in this community). Also the settings cannot be edited ofr any position on iPAD or iPhone – when the edit button is pressed the page just says settings saved. Have cleared cache and tried on Chrome and Safari.

    This is a poor product now and with all the other issues people have been reporting I am not sure how much longer I can stay around supporting it.

    When will a fix for these issues be released?

    Plugin Author Shareaholic

    @shareaholic

    Hi Everyone, we just released an update that we hope should fix any more bugs with the “Edit” button.

    Here is the changelog for 7.0.3.0

    • New feature: You can now center, left AND right align your share buttons!
    • New feature: Added support for custom headers for share buttons! (How-To Instructions)
    • New feature: You can now on / off toggle the “More Options” share button
    • Various bug fixes and performance improvements
    • Cleaned up assets directory, as a result the plugin zip file is now a lot smaller
    • Added a check to ensure multiple versions of Shareaholic are not running at the same time on the same install
    • Bugfix: A host of fixes for the unresponsive “Edit Button” and “General Website Settings” button bug (If you’re still facing this issue, please contact us)

    Make sure to clear your browser cache so ensure you’re running the latest JavaScript code.

    @kblundy I’ve tested the latest update on the iphone and clicking on the “Edit” button brings up the options. Is it working for you now?

    Thanks so much for your help!

    @shareaholic

    Version 7.0.3.0 is much better. I am able to edit settings and I appreciate the new feature “toggle off ‘More Options'”.

    However, I have still an issue: Only facebook icon is displayed on my main page (index). All icons are properly displayed properly. I have tried to clear my browser cache but this does not solve the issue.

    When installing v7.0.3.0, v6.1.3.8 was automatically disabled. Must I uninstall it?

    Sorry – Shareaholic – still not working. On IOS safari – I can see the buttons on my posts (http://newsroom.durhamdiocese.net) but there is no ‘You may also like’ content and the edit button still doesn’t work in the backend. Using Chrome for IOS nothing works – no front end display of buttons or other content and no backend edit capability.

    Still some more work to do I think!!!

    Yes I have cleared the Cache for the browsers and tried on several IOS devices – all the same issue.

    Hi @kblundy!

    I had one of our engineers check for functionality in iOS and everything came up clear. Could you verify that you haven’t disabled JavaScript? Pressing the buttons in the settings panel triggers a JavaScript action to open the edit panes.

    Are things working properly in a non-mobile OS, such as OSX or Windows? I have viewed your site and the apps are visible on my end–they have also been customized. So, I’m hoping everything is working well for you now.

    @didier77

    When you open your Index button placement Edit screen, have your preferences been saved as you expect? Which services do you have selected to appear for your Index and are they set to above or below content? Also, could you please provide me with a URL so that I can take a look at your site? Thanks!

    Hi C Reign,

    The issue is visible on http://lamourduprochain.org.

    “When you open your Index button placement Edit screen, have your preferences been saved as you expect?” Yes.

    I have upgraded to version 7.0.3.1 but still have the issue.

    The services selected are in this order:
    – Facebook
    – Twitter
    – Google+
    – Yahoo Messenger
    – Hotmail
    – Google Mail

    Theme = Fat circle
    Headline = No heading
    Show ‘more options’ button = unchecked
    Layout = Horizontal
    Size = Normal
    Counter = Badge
    Alignment = Center

    Hi C Reign,

    I don’t know why but after a few minutes, the issue has disappeared itself! Maybe a caching issue (not solved by clearing browser cache?)…

    After more tests, I have still the issue with Firefox 22.0. The first time, the main page is loaded only facebook icon is displayed. I have to press F5 (refresh) key to have all icons displayed!

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Unable to edit settings’ is closed to new replies.