Support » Fixing WordPress » Unable to edit posts properly

  • Resolved Sabinooo

    (@sabinooo)


    Hello!

    I am co-admin on a friend’s blog, and I found that, while all the other wordpress blogs where I can publish work fine, his has a problem:

    – it is not possible to switch from HTML to Visual mode (stuck in visual)
    – it is not possible to edit the post slug
    – it is not possible to edit the post’s date, that adds an #edit_timestamp at the end of the URL and nothing more

    At first, I imagined that clearing the browser cache and cookies, and later creating a new admin user might solve it, but it’s still no good.
    I also made sure all the available blog updates had been applied, yep, nothing with that.
    Tried with another browser: same deal.

    I imagine it must mean a script doesn’t load properly, but that much is totally outside of my own level of competence.

    Chrome shows me this in the console’s errors:

    (the blog's url)/wp-admin/load-scripts.php?c=0&load%5B%5D=hoverI…uery-touch-punch,iris,wp-color-picker,editor,wplink,media-upload&ver=4.4.1 Failed to load resource: the server responded with a status of 403 (Forbidden)
    notes-common-v2.js?ver=3.9.1-201603:32 Uncaught ReferenceError: Backbone is not defined
    admin-bar-v2.js:2 Uncaught ReferenceError: _ is not defined
    ccpurge.js?ver=4.4.1:9 ccpurge loaded
    color_picker.js?ver=4.4.1:3 Uncaught TypeError: $(...).wpColorPicker is not a function
    plugin.min.js?ver=4208-20151113:1 Deprecated TinyMCE API call: <target>.onBeforeSetContent.add(..)
    9VM76 extensions::utils:93 Uncaught TypeError: Cannot read property 'impl' of undefinedpublicClass.(anonymous function) @ VM76 extensions::utils:93n @ VM254:4138

    I have no idea if those entries are trivial, or the reason of this issue.

    From the dashboard, I ran a reinstallation of wordpress: no change.

    At this point, I have to give up and come to ask: please, would someone have an idea about the origin of this problem ?
    (A honest precision: this isn’t an important issue for me, this is closer to curiosity, so don’t go invest a huge amount of time in this, I would feel bad!)
    Maybe, who knows, this is a typical issue with a well-known solution, haha.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Sixteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    Thanks James, I should have thought of doing that standard test. I ran it, and it still didn’t fix that issue.

    Sorry about it.

    In a moment of “who cares at this point”, I checked the website’s htaccess, and I found, to my surprise, the origin of the problem.

    There was this part, to prevent hard-abusing the server with the injection of lots of code, added after, I was told, a successful hack years ago:

    RewriteEngine on
    RewriteCond %{REQUEST_URI} .{450}
    RewriteRule (.*) - [F]
    RewriteCond %{QUERY_STRING}  .{450}
    RewriteRule (.*) - [F]

    Basically, with that code, you can’t have the server “execute” an URL of more than 450 chars with code appended to an URL calling for a badly secured thingy.

    Comment the last line of it ( # )… and the problem is gone!?!? O_o

    I have no idea WHY, but, well, I guess it’s all good, now O_o

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Hm, odd. At least you found a fix though!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Unable to edit posts properly’ is closed to new replies.