WordPress.org

Support

Support » How-To and Troubleshooting » Unable to edit posts – nothing works in Editor

Unable to edit posts – nothing works in Editor

  • My Posts Editor is not functional and looks like this: http://bit.ly/SgULK7

    Everything worked fine before I updated to WordPress 3.4.1. Is it some Java Scrip problem??? I have no idea how to fix it… and would really appreciate any help with solving this problem.

    I tried these already but with no success:
    – a different browser
    – deactivated all the plugins
    – changed the theme to Twenty Ten
    – reinstalled WordPress (1. automatically, 2. by overwriting wp-admin and wp-includes with the freshly downloaded folders)
    – toggled between PHP versions 5.3.4 and 5.2.16
    – installed the Use Google Libraries plugin (only worsened the problem)
    – refreshed the cache after each of the above

    I also sometimes see:
    “Internal Server Error” or “Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1089568 bytes)” but simply hitting reload removes this message and WordPress dashboard loads (though the Editor always remains not functional). I changed hosts recently so I cannot say for sure if this is a connected problem or a separate issue. Maybe it’s something to do with the memory allowed for PHP?

Viewing 7 replies - 1 through 7 (of 7 total)
  • That is indeed odd. Just wondering if there is a problem with the web server. I think the only thing that is missing from the list is testing it on a different host or on your own PC, installing XAMPP?

    You might wanna try if you can duplicate the problem, by cloning your site else where (local PC or another host) with this plugin

    http://wordpress.org/extend/plugins/duplicator/

    Looks like a lot of work… Maybe I will first try installing a second WordPress on the same account to see if the clean installation works.

    Could it be that file permissions are set wrong? I use a security plugin and don’t know if it could secure things over the top. But then reinstalling WordPress would have reverted to correct permissions anyway, no?

    (It is 5 am here and i need to go but will get back to this problem asap).

    Thanks.

    If javascript needed for the editor doesn’t have enough permission to be loaded by the web server, then that’s a possibility.

    Yes, I think clean installation will be a good idea, just rule out the possibilities.

    The wp-admin/js folder has permissions set to 755 and the files within this folder to 644.

    So I did a test clean installation of WordPress and it showed that the javascript editor works ok on the server. There are still frequent “Internal Server Errors” and “fatal errors” but I can edit posts.

    I suppose I should maybe do a full clean install of my main WordPress blog to fix the javascript Editor. But how can I restore all the contents? It is a terrifying task…

    OK, by reinstalling WordPress from scratch I managed to get a functional Editor (i then just copied back my wp-config file and the wp-content directory from a backup and it worked 🙂

    The remaining problem is the frequently appearing “Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes)…”

    all right, just in case anybody is after a solution to this problem, here it is – just add this line to wp-config.php:

    define(‘WP_MEMORY_LIMIT’, ’64M’);

    @wpthemes777.com: thank you for your time and suggestions!

    Glad that solved the problem and thanks for sharing the solution.

    Have a nice day!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Unable to edit posts – nothing works in Editor’ is closed to new replies.
Skip to toolbar