Support » Fixing WordPress » unable to edit images in visual mode via the two pop up icons on the image

  • Hi guys
    Just noticed that I can no longer edit or delete my inserted images from the visual editor in a post or page.

    For example, I often want to resize an image after publishing if the line layout is screwed up.

    Normally, I just open the post/page find the image and open up the image editor by clicking the ‘edit image’ icon on the image itself.

    The icons appear on hover over but clicking them does nothing. I have tried disabling all the plugins and have made no big changes recently, other than upgrade to 3.1.

    Any ideas anyone?

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi


    Forum Moderator

    Amending image dimensions via markup isn’t the right way to achieve this. If you were able to do this previously, then it was a bug which may well have been corrected in the most recent version of WordPress.

    Oh, I have always tweeked the images this way over many versions.

    How do you alter images after insertion otherwise?

    I’ll have a look in the docs later!
    Thanks Esmi

    I have the same issue….insert an image….preview how it looks or maybe decide to change the caption. Click on the image and typically what shows up is 2 pictures the edit picture, or the red circle with the line through it.

    Now it shows up, but nothing happens when I click, and then of course I’m unable to make any changes, or even delete the image unless I go into the html and remove the lines.

    I know jtai21, it is still unresolved for me too.

    I had been editing this way for years but now it doesn’t work. The icons still show but they are unclickable.

    I am sure that esmi is wrong (unusually) as the icon states ‘edit image’ on rollover so that must be its function.

    Anyone else have this problem or know why????

    I’m considering downgrading again…to 3.0.4 for the third time. Not being able to edit the image information like caption, or alignment or even deleting is really pointless, and I don’t want to do all of this via html.

    I think esmi may have misunderstood what we’re talking about. I think I’ve read on wordpress that this is how you can work with galleries, or singular images, but I don’t remember for sure.

    I may downgrade this weekend….or tonight if I’m motivated. <sigh>

    It is strange that more are not mentioning it as it is such a core function to be able to easily alter images after insertion.

    I wonder what our set ups have in common.

    I an running the twenty ten theme with only a few basic plugins.
    Here is my list:
    All in one SEO
    Broken link checker
    Dynamic Headers by Nicasio Design
    Post to twitter
    RB Internal Links
    Sexy bookmarks
    Simply Hide Pages
    Subscribe to Comments Reloaded
    TinyMCE Advanced
    W3 Total Cache
    WordPress Database Backup
    WordPress Importer

    Could you post here if the downgrade works for you jtai??

    I did a semi downgrade, meaning this is not a clean way to downgrade, but for now it’s working as I want. Not sure if this is technically correct as I’m not running a pure version (at least I don’t think so). I started to follow Easy WordPress Downgrade

    [Note: I had original WP 3.0.4 download]

    But I didn’t do everything in it. I backed up my database via MyPHP admin. Then I moved all my WP3.1 files into a folder so that if this didn’t work I could put everything back easily.

    Then I went back and copied over all my files from WP 3.0.4 which was the last version I was using. I copied everything but wp-admin and wp-includes since a fresh version comes from the original WP 3.0.4 install files during an upgrade.

    Once that was done, I made sure to have all my customized files in place. I now am running a semi 3.0.4 version.

    When I went back into WP it did ask me to update the database….not exactly sure what it updated or did…I think it did that by default because it knows I replaced virtually all WP files.

    The lower right corner within WP dashboard says I’m running 3.1 but at the top of the Dashboard where it lists the number of Posts, Comments, Spam etc…that says I’m running WP 3.0.4

    The best part is I’m able to edit pictures as I did before. I’m sure I broke a lot of rules in doing this properly and safely, but I did a backup in case the whole thing failed. Try this at your own risk…I’m not well versed in this to help anybody.

    PS – I had disabled all plugins when running 3.1 so I don’t believe plugins were the reason for not being able to edit pictures. I also had them disabled while I did this so-called downgrade. I tried to follow standard “upgrade” rules while doing my downgrade.


    Sorted it, kinda. Well at least identified the problem and you would never guess, its not wordpress…..its a BROWSER bug. I use Chrome and in explorer and firefox the edit/delete image functions work just fine.

    How about that.

    Are you kidding?!?
    I use chrome too! I never even tried from firefox!

    Now….do I go back and reload 3.1?
    That will have to wait, I have other things to do. But THANK YOU ianmanderson for the continued digging!

    I know, but what to do to ‘fix’ it?

    I can’t be bothered to change browsers now, esp not back to Explorer.

    I’ll keep looking. Got to have the edit feature as I am a terrible ‘fiddler’ with layouts after I have posted etc lol

    Thanks for the post. I just spent the last two hours attempting to ‘fix’ the image edit button issue with posted images using the current release of WordPress 3.1.3. Safari on a PC didn’t enable the feature. With Firefox the image edit appears to work as before.

    Your welcome gmoses, I do wonder why it has not been addresses before now though.

    I can’t even find much chatter about it. Maybe all those who count are firefox fans!

    I even have a problem with chrome deleting my youtube links that does not happen with firefox.

    Computers eh!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘unable to edit images in visual mode via the two pop up icons on the image’ is closed to new replies.