Support » Fixing WordPress » Unable to edit category slug

  • prathyushkoka

    (@prathyushkoka)


    Hello,
    Slug field is not being displayed while editing categories. WordPress version 4.6.1

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    1. The current version of WordPress is 4.9.8. 4.6.1 has vulnerabilies. You should update ASAP.

    2. Moved to “fixing wordpress”. “request and feedback” is not the appropriate forum for this topic.

    3. What do you see when you edit a category?

    See https://i.imgur.com/mxQOYQO.png

    prathyushkoka

    (@prathyushkoka)

    Slug field is not present

    https://drive.google.com/open?id=1HCy-2MPsf_vqWNAwAEaYVPCFuGaO2hxU

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    This may be a plugin or theme thing. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    prathyushkoka

    (@prathyushkoka)

    Even after disabling all the plugins and changing the theme, slug field doesn’t show up. It doesn’t appear even while creating the category.
    https://drive.google.com/open?id=1fjnrgRStL-hrcLUaAR2p0Z3nYge_Swvl

    Rachna

    (@rachna90)

    Might be your Slug checkbox is not selected in Screen Options, which is given at top right beside help.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Are you logged in as an administrator? Is this a multisite setup?

    prathyushkoka

    (@prathyushkoka)

    I selected the slug checkbox, even then it doesn’t appear. Yes, i am logged in as an administrator and it is a multisite setup. Same problem while creating tags (slug field doesn’t show up).

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    I think this is definitely a multisite issue. I’ve googled around and found an 8 year old plugin. I don’t know if it requires that you be a super admin or if it’s just not there.

    Josh Feck

    (@builtbynorthby)

    Steve’s correct, it is a multisite issue. I did some checking, and WP multisite has an option to control whether that category slug field is displayed. There’s also a filter hook that can override the option

    Here’s the source documentation:

    https://developer.wordpress.org/reference/functions/global_terms_enabled/

    So for your site, if the global_terms_enabled site option was set the network admin could unset that option by adding this code to a network activated plugin:
    update_site_option('global_terms_enabled', false);
    The code only should be run once, so it needs to be removed after executing. (e.g. add the code to the Hello Dolly plugin, activate the plugin, then deactivate it.)

    However, there is a filter hook that can override this. Since you mentioned that disabling the plugins didn’t help, it’s unlikely that’s what’s happening here. But if there were a filter function in place, adding this code to an activated plugin would restore the option:

    add_filter(
        'global_terms_enabled',
        '__return_false',
        11
    );
    • This reply was modified 12 months ago by  Josh Feck. Reason: added priority to filter function
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unable to edit category slug’ is closed to new replies.