WordPress.org

Support

Support » Alpha/Beta » [Resolved] Unable to Edit Categories ….

[Resolved] Unable to Edit Categories ….

Viewing 10 replies - 1 through 10 (of 10 total)
  • Anything related to taxonomy is giving this error. Maybe the edit-tags.php is not telling WordPress that it was called from WordPress?

    I am having the same exact problem. Any clues?

    Same problem here. Have any of you found a solution?

    You can try the cache reload plugin once i was facing such problem and by instaling this plugin the problem was solved.
    [sig moderated as per the Forum Rules]

    Thanks, the developer of the theme (Sideways) released an update which solved the issue

    Encontrei a solução para esse erro comparando a pag ‘edit-tags.php’ do wordpress 3.0 contra a do wordpress 3.1 e descobrir uma função no inicio da ‘edit-tags.php’ WP3.1 que diz:

    if ( !current_user_can( $tax->cap->manage_terms ) )
    	wp_die( __( 'Cheatin’ uh?' ) );

    Basicamente se o usuario corrente pode ver dentro da variavel tax cap e manage terms o wordpress morre com o erro!

    Acredito que as expressoes estejam erradas, so foi transformar esse if em comentário que pude editar novamente as taxonomias!

    I found the solution to this error by comparing the pay ‘edit-tags.php’ wordpress wordpress 3.0 against 3.1 and find a function at the beginning of the ‘edit-tags.php’ WP3.1 which says:

    if ( !current_user_can( $tax->cap->manage_terms ) )
    	wp_die( __( 'Cheatin’ uh?' ) );

    Basically if the current User can see inside the variable tax cap and manage the terms wordpress dies with the error!

    I think the expressions are wrong turn that was only if I could comment on the taxonomies edit again!

    esmi

    @esmi

    Forum Moderator

    No – read that first line again! If not (!) current_user_can…

    ok, jus healp!

    Has anyone found a clean fix to this issue?

    The problem seems to be related to using Capitals when defining the custom taxonomy. I removed the capital letter from the custom taxonomy slug and it started working again, but still required several queries directly in MySQL to re-associate the old taxonomy data:

    UPDATE wp_term_taxonomy SET taxonomy=’taxonomyslug’ WHERE taxonomy=’TaxonomySlug’

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Unable to Edit Categories ….’ is closed to new replies.