• Resolved qj2121

    (@qj2121)


    Hello,

    I have experienced the issue to fully download files over 200 MB. I realized that someone had asked the same question but I did not find the solution that works for me.

    Some of my file is pretty large, about 20 GB. This file can be downloaded using “add media” instead of easy digital download. So I guess the plugin places some limit. Is there any way I can remove such limit?

    Thank!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Phil Johnston

    (@johnstonphilip)

    Hey there,

    There are no filesize limitations in Easy Digital Downloads. The only limitations will be caused by your web server – which is where the 20GB file will actually sit so that it can be copied when your customers download it.

    If the web server doesn’t have enough storage space or has timeout settings in place, or isn’t powerful enough, it will fail. For files that large, most normal web servers are not able to handle.

    I would recommend taking a look at hosting your large deliverable files on AmazonS3’s storage service as they allow for larger files. You can find the AmazonS3 extension for Easy Digital Downloads (which makes this much simpler) here:

    https://easydigitaldownloads.com/downloads/amazon-s3/

    qj2121

    (@qj2121)

    Hi Phil,

    Thank you so much for prompt reply. Actually, I can successfully download 4 GB files from the web server without using EDD. Is there any difference between links directly posted on the website and links created by EDD?

    Best,
    Qiao

    Plugin Contributor Phil Johnston

    (@johnstonphilip)

    There is if you are using “Forced” as the download method. Try changing it to “Redirect” under “Dashboard” > “Downloads” > “Settings” > “Misc” > “File Downloads” > “Download Method”.

    This will prevent it from being pushed through a PHP script which could be where you are hitting a limitation (in a PHP setting on your webserver).

    qj2121

    (@qj2121)

    Hi Phil,

    Thank you so much for the suggestion. I have changed to Amazon S3 to store all large files and the problem is fixed. I will try the other way you suggested. Hope it works as well.

    Best,
    Qiao

    longman2020

    (@longman2020)

    Hi,
    I had the same problem and I disabled wp super cache and the problem was fixed.
    https://wordpress.org/support/topic/files-with-high-size-are-not-downloaded/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable to Download Large File’ is closed to new replies.