Support » Plugin: WP Document Revisions » Unable to download files after upload

  • Hello,

    I’ve successfully installed the plugin and everything seemed to be working fine up to the point where I wanted to download the file I’ve uploaded through the admin backend. That’s where I got stuck with the error that file cannot be found or has been moved/renamed. I must be doing something wrong, but have no idea what after 3 hours of trial and error. Here’s what I did so far (I’ve installed the plugin on a remote machine running WP 3.4.1, clean installation, no other plugins enabled):

    First, I’ve checked the configuration — the folder where the documents are getting uploaded to is writable (default WP folder where it stores media). Files are getting there alright, and I can see the hash+.ext . However, when I click on either the “View” or “Download” in the backend — no luck. Just to be on the safe side, I’ve manually created another folder that I’ve pointed the plugin to, and ended up with the exact same problem. Files would get uploaded there, but I wouldn’t be able to access them afterwards.

    Then I’ve tried reconfiguring WP permalinks to a different format. That’s where I’ve noticed that permalink that would get generated by the Plugin would call the original file name (e.g. instead of the hash name (e.g. — and of course fail.

    I’ve gone through your discussion with another user and saw that you suggested he enabled FTP (I used the WP browser upload). I’ve tried that as well, but still no go — I end up with the same error.

    To put the problem simply: when I upload a file, it gets converted to a hash-name with the same extension as the original and get stored in the folder alright. But the permalink used to access it calls the original (non-hashed) filename and hence fails to locate the resource on the server.

    What am I missing here?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve got the exact same problem. It’s not a permissions issue either. It just simple fails to download the document after upload. It’ll give a 404 error with the correct permalink name.

    I’ve had some luck with different extensions working. .docx seems to work but the .xlsx extension fails.

    Yup, I’m having the same problem.

    Anybody answer the issue with the file name?

    Once I change the WP site permalink settings off of standard it breaks the plug-in. When I initially installed doc-revisions it was set at standard and it worked. I then change it to month/name and I go back to the doc page and it can’t find any of the docs using the new url.

    I switch it back to standard and then it works again.

    I then delete plugin. Reinstall while month/name is already set. Still doesn’t work until I move it to standard.

    Is this saved somewhere and if so how can I change it?

    Is this a bug?

    I am having the same problem. I just installed the plugin today, and had no problems uploading documents (two PDFs), but get a 404 error when I go to the site and attempt to download the files.

    I have tried customizing the name, and confirmed the files are in the right location in the Uploads folder…but nothing is making sense. Nor is anything fixing the issue.

    @fcde What sort of permalink structure are you using? Have you tried “refreshing” the permalink struct (click “save changes” under the settings->permalink section)?

    @theseyouths — I tried both simply doing a “refresh” as you described with the current documents already uploaded, as well as tried the month and name option with no luck. I also then tried the default permalink option, with no luck.

    So, then I deleted all my documents, went with just one newly uploaded one under each of the previously mentioned permalink settings, and again, nothing.

    I have also tried uploading a new document, and clicking from within the admin console for documents the “Latest Version of the Document: Download” link, and I get a 404 error. Furthermore, once I have uploaded the document, marked it as final, and made it published as a public document, even the permalink generated doesn’t work in a copy/paste to a new browser window. Basically, nothing works.


    Just a few more things:
    1) Can you give a sample of how the permalink looks once you upload a document?
    2) What version of WordPress are you running?
    3) Do you have any extra information about the setup you’re running it on? (ie: Is it a shared host or VPS, what version of PHP are you running, etc)

    Just need some more info because I haven’t been able to recreate this issue yet running WP 3.5.1 with WP Document Revisions 1.3.5. I’m trying to figure out what I need to do in order to trip this bug, so any extra information would help.

    Whenever I try a new plugin that I plan on using a lot – like this one – I test it on a clean install with a default WP theme.

    So latest WP (3.5.1)- clean install.
    Install latest plugin – 1.3.5

    It was able to link to my documents until I switch from standard url name to anything else (I tried month/name first). Anything else other than the standard gets doc not found – because the name the plugin is looking for is not linked to the setting correctly. I am not sure if the app only works for standard naming convention or if it is set in stone (wrongly) because that’s how it was when I did my first install. Haven’t bothered installing this on another clean install with permalink already set because this is not fit for use until the linkage is fixed.

    Also as I have mentioned in another post… I have no revisions section at all – doesn’t exist. My company would be willing to throw money at some upgrades… but again I need to get people using it to sell them on upgrades.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Unable to download files after upload’ is closed to new replies.