Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Unable to disable “follow blog”

  • Resolved Bradex

    (@bradex)


    I have unticked “Show a “follow blog” options in the comment form” under Engagement > Subscriptions. However, the other option “Show a “follow comments” option in the comment form” is ticked.

    Despite this when a user tries to comment, two check boxes are getting displayed.
    – Notify me of new comments via email.
    – Notify me of new posts via email.

    How can I disable the latter and use only the former?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi there! This is a bug, and it’s being tracked here:

    https://github.com/Automattic/jetpack/issues/5769

    It should be fixed in the next release. Until then, you can change those options under Settings > Discussion in your dashboard, at the bottom of the page.

    Thread Starter Bradex

    (@bradex)

    No. My issue is not the same as on the link posted.

    In my case, the settings are not lost after reloading the page. The issue is that disabling ‘follow blog’ does not disable ‘Notify me of new posts via email’ under the comment box.

    Disabling both “follow comments” and “follow blog” successfully removes both “Notify me of new comments via email” and “Notify me of new posts via email” from under the comment box.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    disabling ‘follow blog’ does not disable ‘Notify me of new posts via email’ under the comment box.

    Disabling both “follow comments” and “follow blog” successfully removes both “Notify me of new comments via email” and “Notify me of new posts via email” from under the comment box.

    Does this mean that you can only disable or enable both options at once, but not set them separately? Did I understand correctly?

    Do you experience the same issue when updating the options via Settings > Discussion?

    Thread Starter Bradex

    (@bradex)

    @jeherve You understood correctly!

    Thanks for the tip! Updating the options under Settings > Discussion helped!

    It makes no sense having settings for the same thing in two places. No wonder it did not work earlier!

    I hope that the jetpack team takes note of this issue!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Excellent, I’m glad to hear you could work around the problem!

    It makes no sense having settings for the same thing in two places.

    These settings used to be only available under Settings > Discussion. We decided to make them available in the Jetpack settings screen as well, since that’s where a lot of people go look for those settings (as you did.)

    Obviously, that’s only useful when the toggles and checkboxes actually work! We’ll make sure this is fixed in a future Jetpack release. Thanks for the report!

    Thread Starter Bradex

    (@bradex)

    Thanks for taking note of the issue! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Unable to disable “follow blog”’ is closed to new replies.