Support » Theme: WP-Creativix » Unable to Disable Comments

  • I would like to remove the ability for anyone to comment on both posts and pages. I have unchecked all corresponding comments related items under Settings – Discussion, and all comment boxes, etc. still show up on all pages. In most themes this would usually result in a statement sohwing “comments closed”, but there is no change at all. I do not have posts yet. On pages, there is no option to prevent comments on the admin page itself (page you create a page on), therefore, I cannot even disable commenting on each individual page. I am working with a child theme, and only have the style.css file in my child theme. How would I go about removing all comments everywhere using a child theme?

    Thank you in advance.

    My site is http://www.glutenfreepressrelease.com

Viewing 4 replies - 1 through 4 (of 4 total)
  • Did you try to look in your ‘comments.php‘ file?

    Just install following plugin – http://coffee2code.com/wp-plugins/one-click-close-comments/

    You can close any comment on post/page with just one click.

    I read a post about that plugin. I would rather find a way to do it manually rather adding another plugin on my site, as they slow sites down considerably once you have many installed. Thank you though. I really appreciate your time. I just may end up using it anyway as a temporary fix. Perhaps I can then check the plugin files and see how it is done. Have a good weekend! 🙂

    Darin,

    I looked in there, but I felt the whole file needed to be removed as well as go into every file to see if there comment commands in them. I watched a YouTube video about it, though it wasn’t about my theme, Creativix, there are tons of code you need to remove. Being that I have a child theme, I do not know which files to recreate, and how to do all of that. If I make the changes in the current theme they’ll be overwritten next time the theme is update.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unable to Disable Comments’ is closed to new replies.