Support » Plugin: Wordfence Security - Firewall & Malware Scan » Unable to delete entries from Whitelist URL table

  • Resolved shinerweb

    (@shinerweb)


    I was clearing out a bunch of old entries from my whitelist table left over from the first release that were picked up before 404’s were being ignored. I noticed one entry remained and no matter if I hit the manual delete at the end of the item, or tried a Bulk Delete, it would not remove the item.

    I then noticed an invalid/control character in the Filter URL column.

    /wp-content/themes/mTheme-Unus/css/css.píhp

    I tried both the manual and bulk remove method, refreshed the page to see if it the UI hadn’t updated, and another character appeared after I hit refresh.

    /wp-content/themes/mTheme-Unus/css/css.píhp

    In the end, I did a manual edit of the entry and removed the offending “í” and then the delete function worked.

    I had the same problem on another site I manage, but this time, I couldn’t get it to add an extra “Ô . Again, I couldn’t delete it via any method until I edited and removed the offending character.

    By no means a show stopper, workaround is easy so just a FYI

    https://wordpress.org/plugins/wordfence/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Had another issue today where unable to delete an entry from the firewall table:

    /wp-content/themes/mTheme-Unus/css/css.p­hp
    request.queryString[files]
    10/05/2016, 21:41:59

    Again, had to manually edit the entry to remove the  and was then able to delete that entry.

    Plugin Author WFMattR

    (@wfmattr)

    Hi,

    Thanks for the update. We included a fix for this issue in version 6.1.6. These should also no longer appear in learning mode, since hits that cause a 404 error are no longer whitelisted, unless you have a plugin that redirects/modifies 404 responses.

    If you are still having trouble with the latest version, just let us know. Thanks!

    -Matt R

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Unable to delete entries from Whitelist URL table’ is closed to new replies.