Support » Fixing WordPress » Unable to create wp-content/uploads

  • Hello,

    Even if I know that some other topics exist on this error, I can’t resolve my problem with proposed solutions.

    When I want to upload a media (picture), I have the following error message : Unable to create directory wp-content/uploads/2016/09. Is its parent directory writable by the server ?

    I put 777 permissions on my directory, and I use a full admin account on my provider infrastructure.

    Some precisions : I have installed wordpress not at the root but in a subfolder of my FTP server (/wp) and I didn’t make any configuration (I didn’t find where). My provider is strato (maybe there is some particularities with permissions ?)

    Thank you in advance

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Steve Stern

    (@sterndata)

    First, 777 is a Really Bad Idea. Permissions should be 755/644.

    What do you mean by ” I use a full admin account on my provider infrastructure”?

    In addition to permissions, the directories and files should be owned by the same user under which PHP is being executed.

    Are you using shared hosting or a VPS?

    Yes, I know that it’s not a good idea, but I was wondering if my issue was a permission issue or not.

    I mean that my provider provides me a ftp account to upload my files, I can create some other accounts but they don’t have as much privileges.

    I’m using a share hosting server, so I don’t know wich account is executing PHP (that’s why I put 777 for testing my permissions).

    Maybe I didn’t understand something, but I’m wondering which account is use to upload pictures when I’m on the Dashboard or on the personalization screen.

    Moderator Steve Stern

    (@sterndata)

    If you’re on shared hosting and you get an error like that, it will probably require intervention from the host’s support staff.

    It’s really strange, because if you changed permissions to 777 that mean any user can write.
    Are you 100% sure of that you have wp-content/uploads 777?

    If yes, please check if you don’t have already directories inside uploads with different privileges, e.g. ../uploads/2016/09 with 755.

    As Steve said, it’s not good idea to keep 777 files. It is temporary solution to check where is the problem.

    The problem is not with permissions, it is with the uploads folder path

    Check this guide to solve the problem: [FIXED] Unable to Create Directory wp-content/uploads. Is its Parent Directory Writable by the Server

    The problem must be with the upload folder path … Please check and verify that folder upload path for media is setup correctly.

    1) Login to your WordPress > Dashboard
    2) Go to settings > Media
    3) In the Media > under the “Uploading files” > there will be an option of “Store uploads in this folder”.
    4) Your Media will be stored over here. So, you need to verify that the path entered over here is correct path.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Unable to create wp-content/uploads’ is closed to new replies.