Support » Plugin: WooCommerce » Unable to create order.

  • Resolved user89733

    (@user89733)


    I migrated my website from and old hosting to a new hosting account.
    Everything is alright except 1 problem. When you try to place and order, you get an error “Unable to create order.”..
    It seems the order details are storing in database but they are not visible in the order section. There are “Pending payment (15)” orders. When I click to see the order a blank page appears without order details.

    What should I do now?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter user89733

    (@user89733)

    Here is a screenshot of the order section: https://ibb.co/mDR62f

    Hi,

    what did you do before this problem?

    Are you sure transfer files by FTP is correct?

    Are you sure trasfer MySQL database is correct?

    Plugin Support Hannah S.L. a11n

    (@fernashes)

    Automattic Happiness Engineer

    This is likely going to be a tricky question. I’m going to leave it open for a bit to see if anyone is able to chime in to help you out.

    If you end up needing more hands-on support with this, I recommend reaching out to your host, or working with a developer – in that case, I recommend contacting one of the services on our customizations page: https://woocommerce.com/customizations/

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hi there @user89733

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Thanks,

    Hey, I just transfered my website to my new hosting and had the exact same problem, when making an order, the same error appears and the order page also appears as blank, any idea what might be?

    This is the conversation which i had with my hosting:

    Hey after changing the host, my woocomerce is no allowing me to make more orders. it appears ” Unable to create order.” message
    [11:08:49 PM]Prateesha Pundaje:May I know where do you see “Unable to create order.”?
    [11:08:55 PM]Manuel:my pleasure, do you know what might be happening, i just changed this website from my old hosting on sunday
    [11:09:02 PM]Manuel:In the checkout page
    [11:09:14 PM]Prateesha Pundaje:Could you please provide me the exact URL you are trying to access?
    [11:09:31 PM]Manuel:after selecting the payment methods, when trying to go for the payment page
    [11:09:39 PM]Manuel:https://www.pranichealinglondon.uk/shop/checkout/
    [11:09:41 PM]Manuel:in that page
    [11:10:21 PM]Prateesha Pundaje:Let me check it, please give me 4-5 minutes
    [11:10:34 PM]Manuel:In that page i put the information, slect the method, agree with the T&C, and when clicking to go to the payment page, the unable order message appears
    [11:10:40 PM]Manuel:of course, thank u!
    [11:14:39 PM]Prateesha Pundaje: Thank you for your patience, You are using the Woocommerce plugin for the website right?
    [11:15:49 PM]Manuel:yes
    [11:17:19 PM]Prateesha Pundaje:I could see that the plugin is causing the issue, there might be some settings that needs to be updated on our end, Could you please contact the plugin vendor and ask if there are any server end settings that has to be updated?
    [11:17:40 PM]Prateesha Pundaje:If there are any settings that has to be updated, we would definitely do it on our end.
    [11:18:34 PM]Manuel:sure, i found this link: https://wordpress.org/support/topic/unable-to-add-to-cart-unable-to-create-order/
    [11:18:43 PM]Manuel:Do you think the last comment might be it?
    [11:18:57 PM]Manuel:I dont know how to change it thought, what do u think?
    [11:20:21 PM]Prateesha Pundaje:I am checking it, please give me 4-5 minutes
    [11:20:36 PM]Manuel:sure, thank you!
    [11:22:53 PM]Manuel:by the way, when transfering the website to this hosting, there were 2 databases in the old hosting, but you colleague told me that only one of the DB was enough, the biggest one, because apparently it is 1 database per website, do you think in some way, might be that?
    [11:26:30 PM]Prateesha Pundaje:Absolutely not, that will not cause an issue. I am trying to set the value to post_password.
    [11:26:38 PM]Prateesha Pundaje:please give me 3-5 minutes
    [11:26:53 PM]Manuel:yes, thank u very much
    [11:33:21 PM]Prateesha Pundaje: Thank you for your patience, I am still checking the wp_posts>>password, please give me 3-5 minutes.
    [11:33:48 PM]Manuel:sure, thank you for the notice
    [11:37:47 PM]Prateesha Pundaje: Thank you for your patience, I could see that the post_password is set to VARCHAR(255)
    [11:38:23 PM]Manuel:welcome, i see, so no idea on what the error might be right?
    [11:38:45 PM]Manuel:Shouldn’t it work if i re-install the plugin or something?
    [11:38:58 PM]Manuel:Is it a DB related thing?
    [11:39:12 PM]Prateesha Pundaje:Yes, looks like some settings has to be updated, like max_execution time or something else.
    [11:39:29 PM]Prateesha Pundaje:If they could provide the exact settings , we can update it,
    [11:39:34 PM]Manuel:Is there any further test that you can make?
    [11:40:10 PM]Manuel:I’ll create a ticket with them yes, but they usually take days, if you could test a couple more things I would appreciate

    Any ideas on how this might be solved?

    I just created a ticket on woocomerce website, but if able to solve this before, I would be extremely grateful.

    Thank you all for the help and collaboration

    @manueljcmatos Have you solved the “Unable to create order.” problem?
    My website suddenly occur this problem last week since I’ve updated some plugin (which I don’t remember which one).
    I’ve tried:
    1. Checked the database about wp_post/structure/post_password. (no problem).
    2. Upgraded WP to latest 5.X (Twice, one time auto, one time manual).
    3. Updated Theme to latest version (Betheme, and I’m the only member who had this problem).
    4. Updated Woocommerce to 3.6.4.
    5. Updated Ipay88 (Malaysia Payment portal).
    6. Change the Theme to default Twelveforteen, TwelveXXX (no used).
    7. Deactivate all plugin except Woocommerce (no used).
    8. Call the hosting server company see whether they upgrade server.(no)
    9. Clear all sort of Caches everytime I reset reinstall anything.
    10. Try to reinstall into a exactly same setting and version of WP/Theme/Woocommerce new website under same domain. (New website totally no problem).

    All steps are NO USED at all….the “Unable to create order.” still showing….
    Than later I changed back to old version.
    1. Woocommerce 3.6.4 (not working)
    2. Woocommerce 3.6.(not working)
    3. Woocommerce 3.5.8(not working)
    4. Woocommerce 3.5.2(WORKING)

    Finally I solved the problem with 3.5.2 (which I don’t know why).
    Could Woocommerce team help to see into this problem?
    What is the different between 3.5.2 and 3.5.8 that would cause the “Unable to create order.” problem?
    Because I still need to upgrade later.
    Maybe I should just do a totally new website….

    My website: https://yam.org.my/V2/shop/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Unable to create order.’ is closed to new replies.