Support » Fixing WordPress » Unable to create… local install

  • I am running 3.2.1 with a local install and I’m having issues uploading anything. I’m getting the error message “Unable to create directory C:\Program Files\Ampps\www\wp/c:/program files/ampps/www/wp/wp-content/upload/2011/11. Is its parent directory writable by the server?” I have opened the local folder, taken it off read-only, and it still resorts back to read-only. I don’t know if this is causing the issue or if something else is causing this problem.

    Any suggestions or help would be greatly appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Did you install the server in program files if so it needs be C:\

    It is, I’m using AMPPS as my installer and its located in c:\progam files\ampps

    I just looked up and it need to be C:\
    http://www.ampps.com/wiki/Install

    I have uninstalled Ampps, reinstalled into C:\, however I’m still getting the same error message, “Unable to create directory C:\Ampps\www\wp/c:/ampps/www/wp/wp-content/uploads/2011/11. Is its parent directory writable by the server?”

    ok, there seems to be a coding error in the installing of the script from AMPPS. It seems that the script writes the upload to “C:/Ampps/www/wp/wp-content/uploads/…” I went into the media settings and changed it to “C:\Ampps\www\wp\wp-content\uploads\…” and it has resulted in perfect usage and no more errors. I am not sure if this is something that is normal, however it seems to have fixed the issue so far.

    OK, that worked for me – thanks very much.

    But why is it that installed on a Windows 7 server, it requires me to enter the slashes bass-ackwards?

    Terence.

    Im not sure, the only thing I can think of is its a scripting error done through ampps

    That’s not what I meant. I am sure the error in the script is the reason why it doesn’t work. But what I am getting at is that, for a Windows installation, I would expect to enter “C:/Ampps/www/wp/wp-content/uploads/…” not “C:\Ampps\www\wp\wp-content\uploads\…” – which is typically the Linux way of writing the URL.

    I’m not quite sure, sorry.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unable to create… local install’ is closed to new replies.