Support » Plugin: Pretty Link Lite » Unable to create links or groups

  • Resolved anthonybarro


    Using Pretty Link Lite and I’m unable to create links or groups.

    The plugin is installed as instructed.

    When I go to update the plugin, the updates are recorded. So I don’t think it’s a db connection problem (well I guess it isn’t).

    If I click create new link and follow instructions, it returns me to the main page “admin.php?page=pretty-link” with the message:

    “Your Pretty Link was Successfully Created”

    However, no links are created and/or shown below. It’s the same story with setting up “groups”.

    I’ve tried removing and reinstalling, which does nothing.

    Any suggestions?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Anyone?

    Plugin Author cartpauj


    Can you check your database and see if any prli_* tables exist?

    Negative. No prli_ tables exists in the db. I take it it should set them up when activating the plugin, correct? Well, that doesn’t happen.

    However, interestingly enough when I mess about in “Options”, those are “saved” if you will. Example: under Link Options I check “add nofollow by default” and it will save that. But I still don’t see any prli_ tables.

    Here’s a screenshot of my db:

    I should note, that I’ve tried disabling all plugins and reinstalling/activating Pretty Link, but with same outcome.

    Plugin Author cartpauj


    Deactivate the plugin. Then browse the wp_options table for prli_db_version and delete that row. Then re-activate the plugin and it should create those tables.

    Thanks for that.

    It did indeed result in the plugin creating the tables. However, now I’m back to my original issue, which is:

    I can create links just fine, but when I click them, it just returns a blank page. I’ve tried following the path with the httpheaders extension, but it just “stops” when hitting the newly created link.

    PS: This is the issue that led me to de-activating/re-installing the plugin in the first place — blank pages when visiting created links.

    Any ideas?

    Plugin Author cartpauj


    Well if the tables didn’t exist at first, there’s no way the links would’ve saved. It’s odd that they are still not showing up though now that you have the tables created.
    You said the list is showing as empty, but are any records being saved in the table now?

    I think you’re misunderstanding.

    The tables are now being created as they should, and rows with the links are being saved (thanks).

    What I’m saying is, when a link is created (and saved in the db), any clicks to that link just results in a blank page. As in, if I go to (which should go to, it just returns a completely blank page instead.

    Plugin Author cartpauj


    What are your WordPress Permalinks settings? Also, can you check your PHP error_log for any errors? Your host should be able to let you know where they store the error logs.

    Problem solved.

    Turns out the cache plugin WP Super Cache was interfering. At first I had tried to just disabled it, but I needed to first deactivate the cache feature within the plugin, then delete the cache and THEN deactivate the plugin.

    Pretty Link works now, and you can mark this as solved.

    Thanks for your assistance.

    Plugin Author cartpauj


    WP Super Cache conflict is here (thanks to Richard for finding it):

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Unable to create links or groups’ is closed to new replies.