[resolved] Unable to create directory wp-content/uploads (7 posts)

  1. ft3arc
    Posted 3 years ago #

    When I am trying to upload/import images to my media library, I get the message "Unable to create directory wp-content/uploads. Is its parent directory writable by the server?"
    I see solutions like change permissions to "777", but I am using an SFTP via Fetch. What am I to do?

    Thanks for any advice.

  2. bythegram
    Posted 3 years ago #

    This might help you change the file/folder permissions via Fetch:

    change wp-content permissons to 755

    for more detailed instructions on what the permissions should be, to quote from that page:
    "No directories should ever be given 777, even upload directories. Since the php process is running as the owner of the files, it gets the owners permissions and can write to even a 755 directory."

  3. ft3arc
    Posted 3 years ago #

    I was able to change my wp-content to 755, but still no luck. I even tried adding
    wp-content/uploads manually through the SFTP, and still.....no luck. Oi.

  4. ft3arc
    Posted 3 years ago #

    Oh wait, wait! It's working now. Thank you so much bythegram.

  5. sac65tbird
    Posted 2 years ago #

    For those dealing with this problem on localhost and using an Apache server... You can alternatively change the folder/file user that Apache is using to match what WordPress/PHP is using. If you are on localhost - see this topic with specific details: http://wordpress.org/support/topic/unable-to-create-directory-wp-contentuploads-1

  6. getrippedmusclefast
    Posted 2 years ago #

    Unable to create directory wp-content/uploads/2012/11

    you need to create /uploads/2012/11 folders in filezilla and add 777 permission to those folders

    [sig moderated as per the Forum Rules]

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    No - do not create any folders manually.

Topic Closed

This topic has been closed to new replies.

About this Topic