Support » Fixing WordPress » “Unable to create directory” when uploading files. Tried everything in sticky

  • I just upgraded our church website from 2.2.3 to 2.5.1, and the image uploader does not work. My particular error is this: ANY attempt to upload ANY file (jpg, pdf, doc) causes an error message after “crunching”:
    “Unable to create directory /wp-content/uploads/2008/07. Is its parent directory writable by the server?”

    I found all the support posts on “unable to create directory” and “image uploading problems” and have tried the following:
    1. Changing the file permissions of wp-content (and everything else) to 777
    2. Disabling all plugins
    3. Installing and activating the No Flash uploader (it activates fine, but I still get the same error)
    4. Creating the following .htaccess file and placing it in all directories from the main wordpress one down to wp-content:
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    5. Clearing the browser cache. Clearing it again.
    6. Reinstalling the 2.5.1 wp-admin, wp-includes, and root files
    7. Switching from FF3 to IE6 and back.
    8. Typing in the full URL to uploads under “Miscellaneous”
    9. Unchecking the “Organize my uploads into month- and year-based folders” box under “Miscellaneous”
    10. Removing “www” from the blog addresses under “General”
    None of these attempts had ANY effect on the error message.

    I am stumped. I can probably FTP images and link to them, but many church volunteers post on this web page and most of them have no idea what FTPing is, and really need the WordPress help. Is there anything I am missing?

    Thank you for your help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Well you could try changing to a new upload folder – log onto host, create a new folder in wp-content (ensure its 755) – go to wordpress admin->misc and change the image folder to the new folder and then try uploading.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    The solution to this problem was to delete the text she had put in the uploads section of the Settings->Miscellaneous screen. Having wrong directories there will give wrong results.

    Those settings should almost always be blank. Both of them. Unless you have very special circumstances.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘“Unable to create directory” when uploading files. Tried everything in sticky’ is closed to new replies.