Support » Fixing WordPress » Unable to create directory uploads/2014/06.

  • Resolved graphics616


    I cannot upload pictures to Media any longer. I get the error message:

    Unable to create directory uploads/2014/06. Is its parent directory writable by the server?

    I have changed the permissions of the wp-content, uploads, and 2014 folders to 777 and no go.

    I am using a child theme of the 2013 theme. I changed to several different WordPress themes and tried again. No go.

    I do not know where to go from here to troubleshoot this problem. I seems like a simple permissions problem, but changing permissions is not making any difference.

    What can I do to fix this? Thanks all!

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi


    Forum Moderator

    Ask your hosts to investigate whether you have a folder ownership issue.

    Thanks Esmi.

    I checked with my host and they could find no problems with ownership or permissions.

    I decided to try a fresh install of WordPress. When the fresh install is first instantiated and has no data I can use the uploader for media with no problem. When I update my database with the tables from my existing site, I am no longer able to use the media uploader. I get the same error as above.

    What tables or settings can I check in my database to find this problem?

    P.S. I have optimized my tables and done a repair also and that did not make a difference in this problem.

    Anyone else?

    OK. As usual I figured this out for myself. My database or original installation was corrupted in some way that I was not able to figure out, and that made me unable to upload images. I appeared to be a permissions problem but the host was not able to see any problems there. I fixed my site by doing the following:

    • I reinstalled my original site from my backups.
    • I took screenshots of various screens in the admin area such as plugins, and content blocks, or any other areas in the admin where I needed to remember settings, content, or what was turned on or off.
    • I backed up my database one more time.
    • I backed up my server content.
    • I did an export of my site within the tools/export area of dashboard.
    • I deleted my old files from the server.
    • I created a fresh installation of WordPress on the server complete with a fresh mySQL database.
    • I double checked my new installation to make sure I could now upload media files. I could.
    • I performed an import within the tools/import area of my dashboard.
    • I uploaded my content from my backed up folders such as uploads, theme files, and plugins to the same folders within my new installation.
    • I turned on the same plugins as before.
    • Did one last double check on my ability to upload media files. All is good.

    All in all, didn’t take to long to do these steps. Just remember to have backups of everything, and triple check all your steps.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unable to create directory uploads/2014/06.’ is closed to new replies.