[resolved] 'Unable to create directory uploads/2013/03. (6 posts)

  1. rockstix
    Posted 3 years ago #

    Having trouble uploading any images via my site, whether it be a header or a post image, I get the error message 'Unable to create directory uploads/2013/02. Is its parent directory writable by the server?'
    All permissions are correct as checked by support at Go Daddy and myself. My other subdomain blogs work fine (evening using the same theme) but my main domain gets the error message when adding images. Tried deactivating plugins and tried different themes but get the same result. I can upload images via FTP to the directory without problem but can't access them to insert them into my site. So basically, can't add/upload images from local drive or download them from the server.

    Anybody got some other ideas how to fix this? Thanks.

  2. m0gb0y74
    Posted 3 years ago #


    I'm suffering the exact same problem and have yet to resolve it. If I manage it I'll post here.

    James :-)

  3. rockstix
    Posted 3 years ago #

    I found a solution. Add either or both of these lines to your wp-config.php file (as I'm not sure which one fixed the problem, maybe it was both together).

    define('UPLOADS', '/yourblog/wp-content/uploads');
    define('WP_CONTENT_URL', 'http://yourblog.com/wp-content');

    Obviously replace 'yourblog' with your blog name.

    It will bypass the the directory it can't write to and creates a new directory which it can write to.

    Hope it works for you too.

  4. tlgath
    Posted 3 years ago #

    THANK YOU!! This was driving me crazy.

  5. Nathan Parikh
    Posted 2 years ago #

    Thanks a lot rockstix, this is just what I needed.
    Have a client hosting WP on GoDaddy/Windows Hosting and it is a pain!

  6. g_something
    Posted 2 years ago #

    Just ran into this issue, I was able to get it running with just the first (define 'UPLOADS','xxx') part

Topic Closed

This topic has been closed to new replies.

About this Topic