Support » Fixing WordPress » Unable to create directory locally mac

  • Hi there all –

    I know there are many other threads similar but nothing I can find to suit this situation. If so please show me.

    I’m running OSX 10.6.8 and trying to install a wordpress theme and plugins through XAMPP. So it’s all local. Had trouble with the plugins but just dropped them in in the end via desktop (seemed to work). Next hurdle: Under Tools>Import WordPress I receive the following message:

    “Unable to create directory wp-content/uploads/2014/02. Is its parent directory writable by the server?”

    If you haven’t already guessed, this is my first time. Be gentle.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

    Thread Starter tassgyenes

    (@tassgyenes)

    Thanks Esmi –
    Sounds good but stupid question: how do I change the permissions on that directory on a mac? If I go to the wp-content info dialogue box there is only pure read/write permissions available.

    I’m sorry but I’m not a Mac user, so I cannot offer much in the way of specific help. Have you tried adding full write permissions to the folder?

    Thread Starter tassgyenes

    (@tassgyenes)

    Yeah it has full write permissions.
    I’m even a superuser if you know what that means.

    You might be a superuser but WordPress may not be. Have you tried asking about this on a dedicated MAMP forum?

    @tassgyenes – use terminal.app to use the chmod commands (as noted in esmi’s link) to update permissions.

    Or if you have an FTP client like Transmit, point it at the folder and use Command-I to bring up the private info box and view and edit the permissions there.

    I’m having the same problem. So does this have to use with using MAMP?
    I’m trying to put the site on a local host but can’t upload anything.

    Not themes, plug-ins, nothing. I’m on a Mac.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Unable to create directory locally mac’ is closed to new replies.