WordPress.org

Support

Support » How-To and Troubleshooting » Unable to create directory – Is its parent directory writable by the server?

Unable to create directory – Is its parent directory writable by the server?

  • Hey guys,
    I’m having issues uploading images to to a post. I keep getting the following error:

    Unable to create directory /var/www/vhosts/domain.com/httpdocs/wp-content/uploads/2008/05. Is its parent directory writable by the server?

    /wp-content/ and /uploads/ are both CHMOD’ed to 777.

Viewing 15 replies - 16 through 30 (of 84 total)
  • I have turned php safe mode off. Didn’t help.

    However, changing wp-content directory permission to 777 helped.

    But!

    Changing the permission to 777 is not an answer. Moshu, you have replied in many threads to change wp-content directory to permission to 777, but how come that would solve anything?

    There are several threads about this problem. It’s unbelievable that no one has come up with a good solution 🙁

    Thanks so much to pumpkinslayer. Adding the following to the top of my .htaccess file solved the image upload problem for me:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Never had any problem with images before upgrading to 2.5.1, but as of that version image uploads would not work at all (and my host won’t even let me change permissions to 777 on a directory; that’s no answer). Apparently it’s this mod security stuff that causes the problems.

    Go to General Settings and in WordPress address URL field leave: http://yoursite.com. This one is wrong: http://www.yoursite.com.
    Forget about CHMOD and SafeMode bullshits. It’s a WP bug.

    bow…

    No, Romik84, this problem isn’t connected to sub-domains in any way 🙁

    No, Romik84, this problem isn’t connected to sub-domains in any way 🙁

    For me it was the problem. I have 2 sites and on one it worked and on the second it didn’t. So I compared the settings. And when I removed the “www” in the second one it started working…And it also wrote when I’ve tried to upload: Unable to create directory …/wp-content/uploads/2008/05
    now it works. I have changed both URLs: WordPress address (URL) as well as Blog address (URL)

    Does anyone use 1and1.co.uk for their hosting? I don’t have this problem with my hosting at 1and1.com. It’s very odd. I’ve tried everything on this page and nothing has worked. Hmm….

    I had this problem in WPMU 2.5.

    I tried removing www. from all URL settings, that didn’t fix it. Making sure all directories had the proper owner and group didn’t fix it. Setting wp-content and everything inside to 775 didn’t fix it.

    Finally, when I manually created the directory blogurl/wpcontent/blog.dir/blog#/files and set that directory to 777 it worked.

    I tried backing off that directory to 775, and it quit working, and the error message changes to HTTP Error – An error occurred in the upload please try later. Everything up to the files directory can be 755 and it still is okay.

    I don’t want to leave this directory at 777, I hope someone will post if there is a good solution to this problem.

    preface: i moved my Mu from subdirectories to subdomains. I copied the blog directory from the old location to the new location. I got this error but with a twist

    ‘Unable to create directory…//2008/05’

    that double slash confused me. i tried everything that everyone here tried. then i renamed the numbered blogh directories. directory ‘1’ because ‘1_old’. Mu then recreated the folder properly and everything works.

    I am having the same problem as netman74501 reported above. Uploading works in IE fine, but refuses to work in firefox. Any ideas?

    I BELIEVE I HAVE FOUND A SOLUTION!

    I am using WP 2.6. I CH’MOD (777) the following directories:

    wp-content
    uploads
    *every folder/subfolder with uploads

    I then went to Settings > Miscellaneous > Full URL path to files (optional)

    I put in: http://yourdomain.org/wordpress/wp-content/uploads

    and made sure my uploads were set to:

    wp-content/uploads

    Hope this helps!

    I cannot believe that there is not yet a definitive answer here. Nothing from WP?

    Hello everybody,

    You should give a try to this fix. It worked for me (no need to chmod the ‘uploads’ directory to 777, but you have to be sure the user Apache is running under has enough rights to create any directory below ‘uploads’).

    Cheers,

    Stéphane

    yesterday i had a similar problem with wpmu as pumpkinslayer described.

    here is how i solved it …

    http://mu.wordpress.org/forums/topic.php?id=9077

    I had a similar fix myself. I basically deleted the default path for the “Store uploads in this folder” field in “settings/miscellaneous” and put the full path in the “Full URL path to files (optional)” field.

    Hi, yesterday I got this HTTP error when trying to upload a photo. Then I realized all my blogs had the same problem. I contacted my webhost and they can upload just fine!

    I tried installing the plugin (image upload – HTTP error fix) but I’m still getting the same message: HTTP error. an error occurred during the upload. Pls try again later).

    I am trying to add the text in the htaccess as suggested by Pumpkin Slayer. But can anyone advise me – WHERE can I find the htaccess? I’m not good at these script stuff. Thanks!

Viewing 15 replies - 16 through 30 (of 84 total)
  • The topic ‘Unable to create directory – Is its parent directory writable by the server?’ is closed to new replies.
Skip to toolbar