The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] Unable to create directory Is its parent directory writable by the server? (8 posts)

  1. candrie
    Posted 6 years ago #

    So when trying to use the image uploader, theme uploader, using software like ecto or Macjournal, anything that evolves adding something I get the following error:

    Unable to create directory Is its parent directory writable by the server?

    (I left out the specific URL - I don't think you need it)

    I am assuming(?!) its a permissions thing...

    but what do I need to change it to?

    I have read something about 777 - whatever that is - I have also heard that changing it to that is bad.

    Can someone please help it is getting super frustrating especially when I want to add themes etc from with in the dashboard and I just cant get it to work without:

    Unable to create directory Is its parent directory writable by the server?

    Please please help?

    Thanks in advance!

  2. henkholland
    Posted 6 years ago #

    All about ftp: http://codex.wordpress.org/FTP_Clients

    In an ftp program you can set the admission rights for folders.
    The folder wp-content needs the setting 0755 and the folder uploads (it's inside wp-content) needs 0777 for me.

    Still, my server does not let WP create folders which is needed when you have for example the setting in the WP Dashboard/Settings/Miscellenous ticked where it says: Organize my uploads into month- and year-based folders

    then you also get the "unable to create directory etc".

    FTP avoids all that and it's really easy, like windows explorer (not the browser I mean) but the file and folder manager.

  3. candrie
    Posted 6 years ago #

    Yea but there has to be a way to fix this?

    We should be able to use the front end of wordpress without that error?

  4. henkholland
    Posted 6 years ago #

    I described the way to fix this. You used FTP for the first install or somebody did that for you, then ask that person right?
    Admission rights can also be set through Cpanel or other Shell access programs. Ok, it would be handy if it could be done from WP's backend.

  5. This doesn't seem correct to me. When WordPress automatically creates files and folders, they are owned by the Apache. When you manually create files or folders thru FTP, they will be owned by your database. This would be ok, but then you need to get involved every time someone wants to upload an image or change an avatar, if the folder has not yet been created! There has got to be a way to do this correctly.

  6. mrbdorr
    Posted 6 years ago #

    Do you have Go Daddy hosting? Did you just migrate to a new server?
    I do and did and fixed it this way...

    1) Log into your Hosting Control Center (with Go Daddy)
    2) Copy the "Absolute Hosting Path"
    3) Open a new browser and log into you wp-admin
    4) Goto Setting -> Miscellaneous
    5) Where it says "Store uploads in this folder" - copy what is in there already to something as a backup (in case this all fails)
    6) Paste in your "Absolute Hosting Path" from Go Daddy
    7) Add "/wp-content/uploads" after the Absolute Hosting Path and save settings

    This should fix it =)

  7. wuzisname
    Posted 6 years ago #

    does word-press 3 even have the miscellaneous option????

  8. benfrain
    Posted 5 years ago #

    mrbdorr - thanks for that, just had the same problem and your steps sorted it quick smart. :)

Topic Closed

This topic has been closed to new replies.

About this Topic