Support » Fixing WordPress » "Unable to create directory … Is its parent directory writable by the server"

  • Unable to create directory wp-content/uploads/2016/06. Is its parent directory writable by the server?

    I’ve had this problem for months (probably a year). I’ve harassed my host, they find nothing wrong.

    The last person who posted this issue was just told “make sure it’s writable”. I guarantee, that was the first thing I checked. I have messed with this for MONTHS and am unable to find a way to fix it. I have tried multiple “fixes” posted in older threads to no avail.

    My permissions are set to 755.
    My WordPress is up to date.
    I have no Plugtins activated.
    My Flash is up to date.
    I have cleared caches and tried it in several browsers with no success.
    No javascript errors reporting.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Borge

    (@joeborge0914)

    Kindly check Settings > Media

    File upload path should only be wp-contents/uploads

    other than that like home/user/pulic_html/ should be removed

    Hello snowdragonspirit,

    For which folders have you set the permissions to 755 ? If you have set it for single folder please make it recursive for all directories inside uploads.

    Thanks

    hi, i got the same problem; permissions are set to 755; in settings > media i cannot find a possibility to change/enter a file upload path.

    as a workaround, to upload the favicon i changed the chmod for the uploads folder to 777, uploaded the file successfully and changed it back to 755 afterwards to keep the file system safe. but of course i don’t want to have to change the permissions everytime i want to upload files.

    update: as described above, i have changed the file permissions back to 755. out of curiosity, i then tried to upload another file – and it worked!

    pigsound , thx men!!
    It works for me

    [update: as described above, i have changed the file permissions back to 755. out of curiosity, i then tried to upload another file – and it worked!]

    Thanks Borge, ran into same problem after a WP migration. Your solution fixed it instantly, saving me from another call to support.

    husk3r

    (@husk3r)

    @borge thank you, that fixed my issue, path was still the one in my previous server

    @joeborge0914 is right. It worked for me. Thank you

    pencariuangonline

    (@pencariuangonline)

    @joeborge0914 your tips worked for me!! thanks 🙂

    I had also this problem but I solved very easily.
    JUST FOLLOW THE BELOW INSTRUCTIONS.

    Log into your WordPress admin dashboard
    Go to Media Settings menu (Settings -> Media)
    Enter wp-content/uploads in the “Store uploads in this folder” text box
    Save the changes by hitting the “Save Changes” button and you are done

    Hi there all thank you for your feedback. I am having the same problem after a website migration. Trying to follow @beingtop10 and @joeborge0914 theory.

    When i visit the Settings> Media area, the only options i can see are these below:

    https://www.evernote.com/l/Ajo4DR4mIuBF94OU5JtehakJxoxHS2Zho-M

    Am i visiting the correct location?

    Please help. Thank you.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.