Support » Fixing WordPress » Unable to create directory /home/…/public_html/wp-content/uploads

  • Hello,
    I have encountered the below message when attempting to upload a purchased theme:
    Unable to create directory /home/…/public_html/wp-content/uploads/2011/05. Is its parent directory writable by the server?

    I have read many forum posts about this issue related to uploading media, not specifically themes. Here’s what I have done so far, which has not worked:

    Checked dashboard/media settings. field is blank.
    Changed permissions on wp-content to 755.

    Of note: when I uploaded a theme from within admin, as for all WP updates, I am prompted within the dashboard for my password. I think this has something to do with it–when you upload a theme from computer, I get no prompt. does it want it and doesn’t know how to ask for it in this screen?

    Is there a way to install a theme in FTP so it will work flawlessly?

    Please folks, any help you can offer is appreciated, I need to get this fixed for a client!

    Regards, Rob

Viewing 8 replies - 1 through 8 (of 8 total)
  • mate, go to dashboard/appearance/themes to upload/add a new theme, otherwise you can ftp the purchased theme to the themes folder located at /wp-content/themes

    good luck

    PS. be careful when playing around with folder permissions

    Hey Maoski Potatohead,

    Thanks for the help. I was trying it from within admin (appearances/themes) but that was where I was getting the error message. I took your advice and loaded the theme files via FTP (I didn’t know where to put them) and it worked!!!

    Thanks a mil bro, really appreciate it! This is all kinda new to me.


    Okay, so the theme uploaded nicely.

    Now I still get the same issue when wanting to upload photos, or likely any media.

    Do we think this is a permissions issue, or a path issue?

    On permissions, I have set them to 755 for the wp-content folder. as to paths, I can’t figure out where to correct this. Do I need to go into database? Where?

    Thanks all.


    So does anyone know if I need to update something in the database? I have tried everything I know and have read about here so far, and can’t get it to work.

    Thanks, anyone!


    I’m having the same problem.
    I changed “uploads” to 777 just now and I can upload images.
    Don’t know if it’s safe to set it to 777 though.

    Ben Pollock


    I’m having the same problem uploading media. I look forward to some answers. My upload already was set to 777 but it doesn’t seem to make a difference.

    I had this issue when trying to get WordPress to create anything on my server. A lot of what I read was to CHMOD to 777 or what have you. That still didn’t work, and it is a security issue anyway.

    What worked for me, is making sure the owner (CHOWN) of the files is correct. I couldn’t tell you off hand what that should be in your set up because – it really depends. On a default Ubuntu 10.4 running Apache 2.2.16, for example, the owner should be “www-data” and I put that as the group as well. In my case there was no need to alter permissions at all.

    From the shell, the command would be
    #sudo chown www-data:ww-data /var/www -R

    There may be command line tool to set all folders and files back to default permissions as well. I have used such things in the past…

    Hope this helps somebody!

    I’m having the same problem on my site

    “Windows-8.jpg” has failed to upload due to an error
    Unable to create directory /home/visionaz/public_html/wp-content/uploads/2011/09. Is its parent directory writable by the server?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Unable to create directory /home/…/public_html/wp-content/uploads’ is closed to new replies.