Unable to create directory error when changing header image (5 posts)

  1. jcwords
    Posted 8 years ago #

    I'm not sure which version I'm using-- I downloaded it a couple of weeks ago.

    I am using the theme, Misty Look, by Sadish, and am getting the following error when I try to use the "custom header" feature.
    Unable to create directory /var/www/vhosts/janice-campbell.com/httpdocs/wp-content/2007/03. Is its parent directory writable by the server?

    I have set the permissions of the wp-content folder to rwx, rwx, rwx, but that didn't fix it. I inquired at Sadish's board, but he was flummoxed and suggested I ask here.

    What directory needs to be writable, and what do I change to make it so? I am hosting the site on a VPS with a Plesk interface.

  2. jcwords
    Posted 8 years ago #

    Okay, a quick addendum. I noticed that there was not an /03 directory in /2007, so I created one. Now I have a new message:

    The uploaded file could not be moved to /var/www/vhosts/janice-campbell.com/httpdocs/wp-content/2007/03.

    Does that help? What should I do now?

  3. Doodlebee
    Posted 8 years ago #

    I'm not sure which version I'm using-- I downloaded it a couple of weeks ago.

    You should check and be sure - if you downloaded a couple of weeks ago, that sounds like prior to the major security update. Look at the bottom of your admin screen - it'll tell you. If it's 2.1.1 - upgrade *NOW*.


    Out of curiosity - where is your "uploads" folder? Usually, that URL is "wp-content/uploads/2007/03". There's a setting in your option panel that asks where you want your uploads to go.

    If you changed it so everything is just going to "wp-content" rather than "wp-content/uploads", then yeah, you're going to run into issues. "wp-content" isn't the folder you need to change permissions for. "2007" is. Also, possibly "03". You need to change permissions to 777, upload the file, then go back in and change the permissions back to the regular default (usually 755). WordPress only needs access to the uploads folder once, then it always has it.

    Problem is, though - with your setup, the files are archived by month, so you'll have to do this every *month*. If you have an "uploads" directory (you can name it anything you want) you only have to do it to *that* directory and never think of it again.

  4. jcwords
    Posted 8 years ago #

    Thank you so much. That was hugely helpful. For one thing, I went in and manually created an /03 directory. It still didn't work, so I checked the permissions, and changed those, and then it worked.

    I really appreciate knowing how that works, and I just went and created an 'uploads' directory. So that ought to make life a little easier.

    Are you serious about updating? It is 2.1.1. Does that mean reinstalling and losing all my settings? :-( Or is it not that bad?


  5. Doodlebee
    Posted 8 years ago #

    >>Are you serious about updating? It is 2.1.1.<<

    Hell yes. There's a sticky on this very forum at the top - the 2.1.1 download was compromised. Upgrade *NOW*.

    No, it doesn't mean reinstalling and losing all your settings. But *do* make a backup of your stuff - just in case (I've never had the "just in case" scenario happen, but there's always a first time) - use the WP Backup plugin to backup your posts and stuff (back up *everything* and have the file saved onto your hard drive), and FTP in and backup your themes folder. Plugins, too, if you want.

    Then just upload all of the 2.1.2 files onto your server, navigate to the "upgrade.php" file and go. Nothin' to it. If all goes well, that's it. If it doesn't, you have your backup files.

Topic Closed

This topic has been closed to new replies.

About this Topic