Support » Fixing WordPress » “Unable to create directory” error for media uploader

  • i keep receiving this error when i try to upload a picture:

    Unable to create directory /var/www/vhosts/robahern.com.au/httpdocs/blog/wp-content/uploads/2009/03. Is its parent directory writable by the server?

    I have followed the instructions in the sticky topic: media/uploader help.
    I have re-installed the wp-content and wp-includes folders.

    I think it is a problem with the file permissions, the whole directory under wp-content/uploads is 755. what is the problem have i done something wrong?

Viewing 15 replies - 1 through 15 (of 20 total)
  • is there a way i can change the upload directory? because i dont think that “/var/www/vhosts/” is correct? what does that even mean?

    Ryan S

    (@ryan_accuwebhosting)

    You need to create an upload directory inside wp-content folder. t should be like:
    wp-content/upload. Also, 755 permissions to wp-contents and upload (yes, to both these folders)….

    yep i have just created the folder “upload” under wp-content. both have the 755 permissions.

    what else do you suggest is wrong?

    the error kept on coming up after that, the “cannot create directory” error. I then tried to create the wp-content/uploads/2009/03 manually but then it came up with a new error:

    The uploaded file could not be moved to /var/www/vhosts/robahern.com.au/httpdocs/blog/wp-content/uploads/2009/03.

    so that tells me that there is an error with the file permissions, but i checked and they are all on 755.

    why does no-one reply?

    I’m experiencing the same problem as robahern… does anybody have any further advice?

    From the Codex,

    Some plugins require the /wp-content/ folder be made writeable, but in such cases they will let you know during installation. In some cases, this may require assigning 755 permissions or higher (e.g. 777 on some hosts). The same is true for /wp-content/cache/ and maybe /wp-content/uploads/

    Some have changed to 777 for the first upload and then back to 755 and all worked. Some have called their hosts as some have a security feature on the server that causes the problems. A normal approach is to also disable all plugins and try the upload. Some have gone to a different browser. Some have found the flash uploader to be the problem and use the alternate.

    For the majority of WP users, the image upload feature works fine with no problems so it is something in your environment that is the cause.

    Sorted now thanks. Just needed to change to 777 to use my host.

    If you’re being forced to use 777, add this into a .htaccess file in the upload directory to lock it down a little more…

    IndexIgnore *
    Options All -Indexes
    AddHandler cgi-script .php .php2 .php3 .php4 .php5 .php6 .php7 .php8 .pl .py .jsp .asp .htm .html .shtml .sh .cgi
    Options -ExecCGI
    <Files .htaccess>
    order allow,deny
    deny from all
    </Files>

    im having the same thing .. change the permission to 755 and then back to 777 .. still the same ..deactivate all plugins and try uploading.. still the same …

    Ryan S

    (@ryan_accuwebhosting)

    Yesterday, I had the same error with my wordpress MU.. I tried everything and nothing worked!! Then I assigned 777 permissions to all the folders:

    public_html/wp-content/blogs.dir/1/files/2009/03/.. all these folders must be assigned 777 permissions. also varify that these folders really exists..

    yeah i fixed it too. i just had to set permissions to 777 for all the following directories: …/wp-content/uploads/2009/03

    what i’m doing is setting them to 777 when i want to upload then reseting them straight after.

    thanks for the help guys. thanks ryan.

    Ryan S

    (@ryan_accuwebhosting)

    Sorry, but I would like to give some more light to this issue:

    When we upload files using the media uploader, some folders are automatically created, like 2009, 2008 etc. These folders are created by the php script. By default, these folders have the ownership

    nobody:nobody

    Hence, we must have to assign 777 recursive permission to upload folder.

    I tried EVERYTHING listed above still get the message saving no can do.
    HELP PLEASE!

    Funny, I was having this problem. It was a site that I had moved from my test server to a live server.

    Turns out (after CHMODing folders back and forth for about 20 mins and trying the uploader again and again) I had forgotten to to into SETTINGS>MISCELLANEOUS and change the path to the upload directory back to “wp-content/uploads” – DERRRRR!!!! The URL is right there and I simply did not notice it.

    Thought I’d post this as it’s another possible angle on the problem that might be overlooked by some.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘“Unable to create directory” error for media uploader’ is closed to new replies.