WordPress.org

Support

Support » How-To and Troubleshooting » Unable to create directory

Unable to create directory

  • I have WordPress set up and it’s working fine except when I try to upload an image. I receive the following error message:

    Unable to create directory /var/www/vhosts/schatzky.net/httpdocs/WordPress/wp-content/uploads/2007. Is /var/www/vhosts/schatzky.net/httpdocs/WordPress/wp-content/uploads writable?

    The directory is writable. Any suggestions?

Viewing 4 replies - 1 through 4 (of 4 total)
  • it’s mean you have to set the permissions (CHMOD) of that directory to 775, or 777 if 775 isn’t working for you. CMIIW

    in my case i create the directory using FTP Client and set the “month” of folder to 777.

    in my wp-content/uploads/2007, i’ve some directories:

    01 >> 777
    02 >> 777

    etc.. the “01” or “02” is the directory of the “month” when you placed a pic !

    hope this help !

    Thanks. I did that and now receive this message:

    Warning: move_uploaded_file(): SAFE MODE Restriction in effect. The script whose uid is 10012 is not allowed to access /var/www/vhosts/schatzky.net/httpdocs/WordPress/wp-content/uploads/2007/09 owned by uid 48 in /var/www/vhosts/schatzky.net/httpdocs/WordPress/wp-admin/admin-functions.php on line 1757
    The uploaded file could not be moved to .

    Jeremy Clark

    @jeremyclark13

    Member

    Your host has php safe-mode turned on. You can ask if they’ll disable it but I kinda have a feeling they wont. A way around this might be to disable the monthly organization of the uploads folder. It in the Misc tab of the Options menu in your dashboard. Try turning off this feature and see if you can upload then.

    Thanks for the tip but I get the same error message when I change the Mis Options menu. I’ll contact my host and ask them if they can turn off safe-mode.

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unable to create directory’ is closed to new replies.
Skip to toolbar