WordPress.org

Support

Support » How-To and Troubleshooting » Unable to create directory

Unable to create directory

  • Everytime I try to add images to the post I keep getting this message

    “Unable to create directory /home/fhlinux172/g/geomixes.co.uk/user/htdocs/wp-content/uploads/2009/07. Is its parent directory writable by the server?”

    I upgraded to 2.8 and its just caused no end of bother, ive tried de-activating all the plugins, still got the same message when I went to try again.

    Im really really stuck!

Viewing 8 replies - 1 through 8 (of 8 total)
  • whooami

    @whooami

    Member

    your stuck. what have you done besides deactivating plugins? Have you searched the forums? this is a very common problem.

    You probably want to read through here:

    http://wordpress.org/search/Is+its+parent+directory+writable+by+the+server?forums=1

    No need to be rude!

    Besided de-activating the plugins, Ive re-installed 2.8 twice, Ive tried to downgrade back to 2.7 but cant as host wont let me, Created the folder manually. Thanks for the info will have a look now

    Edit: Thanks for the help, the issue has been resolved. Will know to search properly next time..

    whooami

    @whooami

    Member

    No need to be rude!

    I wasnt rude. youre reading emotion into writing that doesnt convey anything except exactly whats written there. By those standards, you were just as rude.

    Please, Geo77, how did you solve this problem, as I have also taken all the steps you did, AND searched the forums ms whooami, and taken all of the steps suggested and still have not solved this very same problem.

    Hi Riverwillow,

    The default WordPress doesn’t contain the “uploads” directory inside wp-content directory. You’ll have to create it manually and change its permission to 777.

    That is the only solution, I hope this helps.

    You may want to try the change mentioned here: http://wordpress.org/support/topic/301275 It worked for me 😀

    Yes izulien that is what worked for me… took out the long file name and just put in the default with out the leading /
    YOU SHOULD NEVER CHANGE ANY PERMISSION TO 777.
    That is a a hackers dream…
    ;0)

    Hi,

    Assign 766 recursive permissions to wp-contents directory from SSH. If you does not have an access of SSH then contact your hosting service provider to grant the permissions.

    Permissions 777 may cause the hacking issue.

    Thanks,

    Shane G.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Unable to create directory’ is closed to new replies.
Skip to toolbar