Support » Fixing WordPress » Unable to create categories

  • Hi there,

    Every time I try to create a new blog category, nothing happens. No error message, no blank refresh, nothing.

    I then deactivated all plugins and did a fresh install of the most recent version. I cleared the cache (and cookies) and tried several browsers to see if something changed. No changes ocurred.

    After that, I did a downgrade to 2.1.3. Still no luck.

    Anyone knows how to fix this problem? Many of the threads I have read seem a bit random and vary from person to person.


Viewing 15 replies - 1 through 15 (of 15 total)
  • Any chance DianeV’s suggestion here helps?

    No sorry, it didn’t work.

    From your previous post about not being able to delete comments, I suppose you’ve tried disabling your plugins with no good result.

    Getting no error message is the curious thing.

    I seen a user getting a message

    You don't have permission to access /wordpress/wp-admin/xxx

    but that has been solved by the .htaccess fixes that are explained in

    There’s currently two trac tickets that are reporting problems with categories, but in both cases they are getting the message “you don’t have permission to do that”. #3807 has a proposed fix.

    Just throwing ideas out…

    Yeah, I always disable the plugins and activate them one-by-one to see if one of them is the culprit.

    I don’t get error messages whatsoever. I simply click the “Add Category” button and it does nothing.

    I’ve had this same problem and it IS related to .htaccess somehow. I hope it can be fixed at some point.

    I found a solution that seems to work. Try logging into WP admin using the non-www address of your site. In other words, rather than I had problems with creating categories, adding links to a post using the rich editor, and other stuff. This seems to have solved all of them.

    This solution is a pain in the butt if you’ve rewritten your .htaccess to push toward the www version of your site. I use a www redirect plugin, so it’s just a matter of temporarily turning it off while I post.

    Thanks for your reply engamerpt, it worked like a charm.

    I already tried disabling the said plugin, but never tried acessing the admincp via the non-www version of the site.

    Still, wordpress developers must address this problem. Although isn’t hard to disable the plugin when you need to create a category, it’s certainly annoying.

    Thanks again for your help.

    Happy to help. I agree … it’s obviously something that needs to be addressed. It’s not in EVERY installation, though, which is strange. I have two active blogs. One is on ver. 2.1 (which I’m preparing to update) and one I just updated to 2.2. The one on 2.1 has this problem, but the one on 2.2 doesn’t. However, I’ve heard of people having this category problem (and the add link problem, which must be related) in versions 2.1 and beyond.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Your WP website only has one URL, and that’s the URL on the Options->General page. If you’re using something other than that, then yeah, I expect a lot of things won’t work. That included.

    Pick which one you want, www or no-www and then set the URL’s on the Options->General page accordingly. Then add rules to .htaccess to automatically forward all users to the one you want them on.

    Rules for forwarding to the non-www site can be found here:

    Otto — you rule. That’s the solution to all of these problems. I didn’t realize that when GoDaddy did the initial installation of WordPress for me that it set the non-www URL as the address of the blog. I switched it to the www version, which I have been using to log in, and everything appears to work great!

    MichaelH- DianeV’s suggestion on the permalinks was the solution I needed. Whenever I clicked on one of my categories, I got a 404. Turns out I had set up a custom permalink structure without knowing what I was doing. Changed it to “Date & Name based”, now everything works fine.

    All I have to say is THANKS GOD for that AMAZING post by Otto!… I was about to crack my head open about this problem since I did modify the .htaccess file to direct all my traffic to the www. version. (canonicalization problem)

    After 48 hours of continuous work I detected the problem and just thinking of spending another 48 hours more redoing everything made me wanna puke ….

    So I chilaxed, grabbed a beer and here we are!

    Thank you guys! (^_^)

    THANK-YOU SO MUCH Otto42 for your reply, I realised I was using the non-www to login to wp-admin which is why my categories and visual editor weren’t working! You have saved me hours of stress, thanks!

    hi – sorry, am new to this, seem to have the same problem but dont know how to – as otto said –

    add rules to .htaccess

    where do i find that file?
    what rules to add how?

    thank you for some help on this one.



    hi. having this same issue.

    however, i can add 2 categories, but they stop at that with a message which reads: “name of last category added” has been saved.

    my Options have url set as http://www.mysite… tried only removing www. with no effect. after removing www. with no effects i download the .htaccess file from my server to modify RewriteEngine On (per but i can’t even see the file on my desktop to modify it. ?? i’m on a mac running osx.

    thing is, i didn’t have problems posting categories in the past. this is the 3rd blog i’ve set up at various sites on this server (ace-net if it matters), for none of which i’ve encountered this problem before.
    why would the scenario change?
    i’m using wp 2.3.1.


    Here is how you can add a category. Create the category and then make your 1st post on it to appear. In this way after you make your first post on that new category, it will apear. This solves the problem 100% related to categories problem.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Unable to create categories’ is closed to new replies.