Support » Plugin: User Access Manager » Unable to create a new group : (

  • Resolved Sunrise12


    I used to have this plugin working great on an old server. Now I’m setting it up in a new location …or I’m trying to set it up.

    I keep creating a new user group and saving it but then nothing actually saves.

    I tried uninstalling and reinstalling the plugin but that didn’t work. I also tried temporarily deactivating the other plugins to see if that would help but that didn’t work either.

    This new server is on a secure https domain and I am wondering if that is caausing a conflict.

    Any ideas or tips on how I can get this working again?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I checked my database and the two tables that should have been created for UAM were never generated: _uam_accessgroups and _uam_accessgroup_to_object.

    When I created a new usergroup from the plugin, a message indicated that the new group was successfully added but wasn’t.

    I was able to add a user group successfully on another host and website so I know the plugin still works.

    The one that is not working has SSL and I’m wondering if that is blocking the installation but shouldn’t.

    I’m also wondering if it thinks that it is a multisite setup because I was testing the site after moving it to the new host at the same time that the old database was still hooked up to the old one. But that should not be an issue now.

    I really want to get this plugin working properly.

    Should I add the two tables manually? If so, do I just “just” need to add the two tables mentioned above or is there more to it than that?

    Or is there another suggestion to try?

    Please advise.

    Another thing that occurred to me is that I restricted the permissions on the database to the basics that were recommended in the WP Codex such as Insert and Delete and removed actions like Create.

    Perhaps that is needed for this plugin to properly set up a new usergroup.

    What are the necessary requirements for the database?

    I solved the problem! : )

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Unable to create a new group : (’ is closed to new replies.