Support » Plugin: WooCommerce PayPal Powered by Braintree Payment Gateway » Unable to connect with Braintree on a staging website

  • Resolved InventLabs

    (@inventlabs)


    Hi guys,

    I’ve installed the latest version plugin onto as staging website e.g., staging.mydomain.com and I’d like to use it in sandbox mode. But there’s a problem.

    After clicking the ‘connect in sandbox mode’ link and following the steps successfully, I reach a step with some information on redirecting back to my site’s WP ADMIN area and a button, however instead of redirecting back to staging.mydomain.com it says redirect to mydomain.com and so I’m unable to complete the setup.

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor danieldudzic

    (@danieldudzic)

    Automattic Happiness Engineer

    Hi there!

    Please open a ticket with our support team via http://www.WooCommerce.com ( Go to Support > Helpdesk > Create a ticket > Free Plugins ), so that we can investigate this further. Please make sure to include a temporary Administrator username and password with your message, so that our team can take a look at your site.

    Cheers!
    Danny

    I had a similar problem with my host, Siteground. They use domain masking techniques to make it easier to push staging sites to the live site. Unfortunately these cause Braintree to see the staging site domain as the live domain. The only solution I found was to make a subdomain (eg. dev.mydomain.com) that doesn’t use the staging feature offered by Siteground and load a copy of my site on that. You’d have to contact your host for help on how best to do that.

    @sprobot Thanks for your well considered and technically clear input.

    Ivan Stefanov

    (@iv3rson76)

    SiteGround Representative

    @sprobot, due to the way how the Staging software is working at the moment, when there are plugins/themes that heavily rely on the WordPress siteurl and home settings from the options table, the best course of action is to temporary add:

    define('WP_HOME','http://staging1.example.com');
    define('WP_SITEURL','http://staging1.example.com');

    into the wp-config.php file of the staging file. Keep in mind that if you push the staging site to live, you will need to verify that aforementioned lines are removed from the wp-config.php file of the live site.

    @iv3rson76 Thanks! I’ll try that. I mainly use the staging site to make sure new and newly updated plugins don’t break anything. I don’t push it to live as I don’t want to overwrite customer data in the database. If I need to make non-database related changes to my live site I just manually upload them. So far using a subdomain with another installation of wordpress in a subfolder of my public_html folder has worked well enough for those times I need to check a plugin like this one where it needs the correct site url.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable to connect with Braintree on a staging website’ is closed to new replies.