WordPress.org

Support

Support » How-To and Troubleshooting » unable to connect to downloads.wordpress.org:80 (Connection refused)

unable to connect to downloads.wordpress.org:80 (Connection refused)

  • Hi!

    After moving to a new hosting, the plugin auto update feature stops working 🙁

    I check the phpinfo (using php 5.2.6) and I have this in the configure command:

    ‘./configure’ ‘–prefix=/usr/local’ ‘–with-ming=/usr/local’ ‘–with-gd’ ‘–enable-gd-native-ttf=/usr’ ‘–with-png-dir=/usr’ ‘–with-mysqli=/usr/bin/mysql_config’ ‘–enable-wddx’ ‘–enable-discard-path’ ‘–with-config-file-path=/usr/local/lib’ ‘–enable-sigchild’ ‘–enable-magic-quotes’ ‘–enable-short-tags’ ‘–with-exec-dir=/home/’ ‘–with-openssl=/usr’ ‘–disable-rpath’ ‘–enable-libgcc’ ‘–disable-pic’ ‘–with-zlib=/usr’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–with-curl=/usr’ ‘–with-gdbm=/usr’ ‘–with-db3=/usr’ ‘–enable-dbase’ ‘–enable-xslt=/usr’ ‘–with-xslt-sablot=/usr’ ‘–with-dom=/usr’ ‘–with-dom-xslt=/usr’ ‘–with-dom-exslt=/usr’ ‘–enable-filepro’ ‘–enable-ftp’ ‘–with-gettext=/usr’ ‘–with-imap=/var/log/ovh/imap-2004g/’ ‘–with-kerberos’ ‘–with-imap-ssl=/var/log/ovh/imap-2004g/’ ‘–with-mcrypt=/usr’ ‘–with-mhash=/usr’ ‘–with-mysql=/usr’ ‘–with-pdflib=/var/log/ovh/PDFlib-7.0.0-Linux/bind/c’ ‘–with-jpeg-dir=/usr’ ‘–with-tiff-dir=/usr’ ‘–enable-exif’ ‘–with-sablot=/usr’ ‘–enable-trans-sid’ ‘–with-regex=system’ ‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-zip’ ‘–enable-inline-optimization’ ‘–with-ttf=/usr’ ‘–enable-soap’ ‘–enable-mbstring’ ‘–enable-mbregex’ ‘–with-gnu-ld’ ‘–with-xml’ ‘–with-libxml-dir’ ‘–enable-shared=yes’ ‘–enable-static=yes’ ‘–with-xsl=/usr’ ‘–enable-track-vars’ ‘–enable-sockets’ ‘–with-xmlrpc’ ‘–with-expat-dir=/usr’ ‘–with-iconv’ ‘–enable-pdo’ ‘–with-pdo-mysql=/usr’ ‘–with-xpm-dir=/usr’ ‘–with-t1lib=/usr’ ‘–with-pcre-regex=/usr’ ‘–with-freetype-dir=/usr’ ‘–with-pspell’ ‘–with-pgsql=/usr’ ‘–with-gmp’

    And this in other related info:

    Registered streams sockets transport: tcp, udp, unix, udg, ssl, sslv3, sslv2, tls

    Sockets support: Enabled

    So I think that I have all ok in the hosting service…

    Then I used the WP FS Tester plugin to test the auto update system, and then I get errors only in two sections:

    Downloading a zip: Warning: fsockopen() [function.fsockopen]: unable to connect to downloads.wordpress.org:80 (Connection refused) in /path/to/myblog/wp-includes/class-snoopy.php on line 1157
    Downloading http://downloads.wordpress.org/plugin/akismet.zip… Suceeded

    Extracting zip: Catchable fatal error: Object of class WP_Error could not be converted to string in /path/to/myblog/wp-admin/includes/class-pclzip.php on line 1402

    Please, can someone help??

  • The topic ‘unable to connect to downloads.wordpress.org:80 (Connection refused)’ is closed to new replies.
Skip to toolbar