• Resolved Marc Nilius

    (@zottto)


    Hi,

    I’m using NinjaFirewall on quite some WordPress installations and normally everything is working fine. I now tried to install and activate the plugin on another installation. This server uses nginx.

    After activating the plugin, I tried to configure it. I chose “Full WAF mode” and in the next screen, “nginx” is pre-selected in the dropdown. If I continue by clicking the “Next step” button, the page reloads but opens the exact same page again. The configuration process never gets to the next page where the config option is shown and added to the config file (automatically or manually).

    What can cause this error?

    Thanks,
    Marc

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Hi,

    Can you run this script: https://nintechnet.com/share/wp-check.txt

    1. Rename this file to “wp-check.php”.
    2. Upload it into your WordPress root folder.
    3. Go to http://YOUR WEBSITE/wp-check.php
    4. Delete it afterwards.

    Thread Starter Marc Nilius

    (@zottto)

    Hi,

    the script’s output (real domain name changed to “my-domainname”):

    NinjaFirewall (WP edition) troubleshooter

    HTTP server : nginx/1.6.3
    PHP version : 5.6.16
    PHP SAPI : FPM-FCGI

    auto_prepend_file : none
    NinjaFirewall detection : NinjaFirewall is not loaded

    Loaded INI file : /etc/php.ini
    user_ini.filename : .user.ini
    user_ini.cache_ttl : 300 seconds
    User PHP INI : none found

    DOCUMENT_ROOT : /var/www/my-domainname/htdocs
    wp-config.php : found in /var/www/my-domainname/wp-config.php

    Thanks,
    Marc

    Plugin Author nintechnet

    (@nintechnet)

    With your configuration, I would select “.user.ini” and, at the end of the installation process, I would restart PHP-FPM so that it would reload the INI file.

    Thread Starter Marc Nilius

    (@zottto)

    That’s what I did. But after selecting .user.ini and clicking “Next Step” nothing happens and the exact same page just reloads. No error message, no next step.

    Plugin Author nintechnet

    (@nintechnet)

    Normally, when NinjaFirewall redirects to that page, it displays a message with the corresponding error.
    If there is no message, there may be a PHP error, or a connection issue (after that page, it downloads its rules). Did you try to enable WP_DEBUG in your wp-config.php file ( https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG )?

    Thread Starter Marc Nilius

    (@zottto)

    Hi,

    I looked into the error log and found the following lines (anonymized):

    2017/03/09 12:07:58 [error] 22034#0: *343426 FastCGI sent in stderr: “PHP message: PHP Warning: session_start(): open(/var/run/php-fpm/sess_xxxxxx, O_RDWR) failed: Permission denied (13) in xxxxx/wp-content/plugins/ninjafirewall/ninjafirewall.php on line 47” while reading response header from upstream, client: xxxxx, server: xxxx, request: “POST /wp-admin/admin.php?page=NinjaFirewall HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “xxxxx”, referrer: “http://xxxxx/wp-admin/admin.php?page=NinjaFirewall”
    2017/03/09 12:07:58 [error] 22034#0: *343426 FastCGI sent in stderr: “PHP message: PHP Warning: Unknown: open(/var/run/php-fpm/sess_xxxxx, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    PHP message: PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/run/php-fpm) in Unknown on line 0” while reading upstream, client: xxxxxx, server: xxxxx, request: “POST /wp-admin/admin.php?page=NinjaFirewall HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “xxxxx”, referrer: “http://xxxxx/wp-admin/admin.php?page=NinjaFirewall”

    Is that the problem and how could it be resolved? Everything else on the installation is working perfectly fine.

    Thanks again for your help!

    Marc

    Plugin Author nintechnet

    (@nintechnet)

    Yes, that is likely the issue, the firewall relies on session during the setup process.
    Your problem is that PHP session files cannot be saved to their folder (/var/run/php-fpm/) because it is not writable by the PHP user.
    You need either to make it writable by the PHP user or to change the path to another writable folder (it can be done by modifying the session.save_path directive in your PHP INI file).

    Thread Starter Marc Nilius

    (@zottto)

    Thanks a lot! I will ask the server admin to fix this!

    Thanks,
    Marc

    Thread Starter Marc Nilius

    (@zottto)

    The server admin fixed the permission problem and now the plugin is working as expected. Thanks again for your help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unable to configure plugin’ is closed to new replies.