Support » Plugin: WP Mail SMTP by WPForms - The Most Popular SMTP and Email Log Plugin » Unable to complete setup – 504 timeout error

  • Resolved Arthur

    (@aahkendall)


    Hi,
    I’m having trouble with a contact form which uses WP Mail SMTP to send emails. I have tried setting up a new WP install and running the setup wizard, but I’m getting a 504, Gateway Timeout error. I am using the same email address and the credentials are correct. In fact, on the live site the general contact form seems to send emails, although the form does not display a confirmation message (nothing happens on the front end).

    I’m looking here before going to the plugin/theme developer (Essential Real Estate/G5 Beyot theme) because I am getting stuck at the set up stage on the new install, before even trying it with forms.

    Any thoughts?

    Thanks,
    Arthur

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @aahkendall,

    Thanks for reaching. Could you please share the SMTP settings you’re using? The timeout error can occur when you’re site is attempting to connect to the SMTP server you configured but couldn’t connect and eventually timed out.

    In fact, on the live site the general contact form seems to send emails,

    If the emails are sent, it may be that the SMTP is set up correctly.

    The form does not display a confirmation message (nothing happens on the front end)

    It is likely the issue with the form if the emails are sent successfully but the form does not display a confirmation message.

    Regards,

    Thread Starter Arthur

    (@aahkendall)

    Thanks for the reply.

    Could you please share the SMTP settings you’re using?

    I am using the settings given by SiteGround – domain as server name, email as username and port 465. Does your plugin support this port?

    It is likely the issue with the form

    As I said, the new install fails/times out before the forms have been setup. It is odd that on the live site the general contact form does work, though.

    If you could just answer the query about the port and anything else you can think of, I will then try the developer (they were very unhelpful when I queried a basic missing feature after the purchase).

    Thanks,

    Hi @aahkendall,

    Thanks for the details! In that case, you might need to contact the SiteGround team to look into the issue, they are probably not allowing outbound SMTP connections.

    Regards,

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Unable to complete setup – 504 timeout error’ is closed to new replies.