Support » Plugin: WP Instagram Widget » Unable to communicate with Instagram.

  • From the beginning this widget show me that it’s unable to communicate with Instagram. So my photo’s don’t show up!

    Thanks for your help!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Scott (@scottsweb)

    (@scottsweb)

    Hi. Some hosts block outbound requests by default. I would check with your hosting company to make sure that you are able to make external requests to instagram.com.

    Hey,

    I started getting this error. Would it be related with my hosting provider or did something change on the Instagram side of things?

    Скотт, у меня такая же проблемма 🙁

    Hello Scott!
    I keep getting the same messages as above “Instagram did not return a 200.” or “Unable to communicate with Instagram”. I contacted my provider, they said everything looks fine. The widget worked 2 days ago… My site is https://mirenamade.com
    Thank you in advance

    • This reply was modified 4 months, 3 weeks ago by  mirenageraki.
    Plugin Author Scott (@scottsweb)

    (@scottsweb)

    Hard to know what is happening for certain. Sometimes Instagram makes changes to their website that breaks the plugin, at the moment it continues to work for me though so I cannot confirm this is the issue.

    > Instagram did not return a 200

    This could be a sign that Instagram is blocking your site if it is making too many requests.

    You would need to be confident in modifying code to debug it fully, if you are happy to edit code add:

    print_r( $remote['headers'] );
    print_r( $remote['body'] );
    

    here: https://github.com/scottsweb/wp-instagram-widget/blob/master/wp-instagram-widget.php#L206

    and report back what you see.

    I saw the same error in several blogs. Example: https://www.instagram.com/hucilluc/

    Here is the result of that print_r:

    Requests_Utility_CaseInsensitiveDictionary Object ( [data:protected] => Array ( [content-type] => text/html; charset=utf-8 [cache-control] => private, no-cache, no-store, must-revalidate [pragma] => no-cache [expires] => Sat, 01 Jan 2000 00:00:00 GMT [vary] => Accept-Language, Cookie [content-language] => en [date] => Tue, 04 Dec 2018 19:43:51 GMT [strict-transport-security] => max-age=60 [x-frame-options] => SAMEORIGIN [content-security-policy] => report-uri https://www.instagram.com/security/csp_report/; default-src 'self' https://www.instagram.com; img-src https: data: blob:; font-src https: data:; media-src 'self' blob: https://www.instagram.com https://*.cdninstagram.com https://*.fbcdn.net; manifest-src 'self' https://www.instagram.com; script-src 'self' https://instagram.com https://www.instagram.com https://*.www.instagram.com https://*.cdninstagram.com wss://www.instagram.com https://*.facebook.com https://*.fbcdn.net https://*.facebook.net 'unsafe-inline' 'unsafe-eval' blob:; style-src 'self' https://*.www.instagram.com https://www.instagram.com 'unsafe-inline'; connect-src 'self' https://instagram.com https://www.instagram.com https://*.www.instagram.com https://graph.instagram.com https://*.graph.instagram.com https://*.cdninstagram.com https://api.instagram.com wss://www.instagram.com wss://edge-chat.instagram.com https://*.facebook.com https://*.fbcdn.net https://*.facebook.net chrome-extension://boadgeojelhgndaghljhdicfkmllpafd; worker-src 'self' https://www.instagram.com; frame-src 'self' https://instagram.com https://www.instagram.com https://staticxx.facebook.com https://www.facebook.com https://web.facebook.com https://connect.facebook.net https://m.facebook.com; object-src 'none'; upgrade-insecure-requests [x-content-type-options] => nosniff [x-xss-protection] => 0 [content-length] => 19596 ) )

    • This reply was modified 4 months, 2 weeks ago by  Steven Stern.
    • This reply was modified 4 months, 2 weeks ago by  Steven Stern.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.