WordPress.org

Forums

W3 Total Cache
"Unable to communicate with CloudFlare API: CloudFlare requires 'email' to be se (13 posts)

  1. Chad Warner
    Member
    Posted 1 year ago #

    I just upgraded 3 sites to W3TC 0.9.4. All sites use CloudFlare, so I activated the new CloudFlare extension. On General Settings my CloudFlare details had been wiped out, so I re-entered. Upon saving, all 3 sites show

    Unable to communicate with CloudFlare API: CloudFlare requires "email" to be set..
    I have tried re-pasting and re-typing my email address to no avail.

    I tried flushing all caches, but that didn't help. These 3 sites are on 2 different hosts (SiteGround and Bluehost). Is there something else I should do to make this CloudFlare extension work?

    https://wordpress.org/plugins/w3-total-cache/

  2. onerock
    Member
    Posted 1 year ago #

    I found that submitting twice the same information seemed to fix my issue.

  3. Chad Warner
    Member
    Posted 1 year ago #

    Thanks, onerock. I tried a few more sites. For 5 of them, I initially got that error, but if I clicked "Save all settings" again, without changing anything, then the error went away. I still have the error on one site, no matter how many times I save.

  4. Wanderlusters
    Member
    Posted 1 year ago #

    Same issue here.

  5. sorin.sfirlogea
    Member
    Posted 1 year ago #

    I got the same issue.

  6. scidox
    Member
    Posted 1 year ago #

    Same issue here

  7. kajari
    Member
    Posted 1 year ago #

    me too

  8. Watch Teller
    Member
    Posted 1 year ago #

    Same to 0.9.3. I dont think problem on W3TC.

    Previously had worked without key in CloudFlare API.

    Currently minified CSS files not refresh or Cron Job not trigger CSS minified file to refresh, therefore came back to key in CloudFlare API at W3TC.

    WP-Control (cron job management) show some warning:
    1. Failed to connect to 2400:cb00:2048:1::6ca2:c75c: Network is unreachable;

    W3TC show some warning:
    1. Unable to communicate with CloudFlare API: Setting: async Resolving host timed out: http://www.cloudflare.com;

    Wish any solution update here soon.

    Thanks

  9. Watch Teller
    Member
    Posted 1 year ago #

    Hi All,

    Feedback: Currently the CloudFlare ipv6 was not function well, please ensure you ipv4 work. After I updated (in wp-content/w3tc-config/master.php) the CloudFlare new IPs, CloudFlare API request was successful.

    Herewith the new ipv4 and ipv6 lists for your review and checking.

    Pls inform that my 2 sites IPs list was totally different (weird). You can review you wp-content/w3tc-config/master.php (not in the wp-content/cache/config/master.php).

    Please backup/keep a copy your old IPs lists for safety purposes

    MY IS WORK NOW.

  10. guiman87
    Member
    Posted 1 year ago #

    Cool.. mine is working now with the IP list updated.

    Thanks!

  11. tmarsh1
    Member
    Posted 1 year ago #

    Same issue

    My API token and email are correct

    Unable to communicate with CloudFlare API: Setting: async Invalid token or email.

  12. damoncloudflare
    Member
    Posted 1 year ago #

    It sounds like W3TC may not have all of CloudFlare's IPs set or something for IPv6. Have you tried the suggestions posted earlier in the thread?

  13. Holy Grailz
    Member
    Posted 1 year ago #

    Same problem here! So how do I update my IP list? I have no IP's listed under cloudflare in wp-content/w3tc-config/master.php. I appreciate your help. Thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic