Support » Plugins » Hacks » Unable to commit to plugin svn: "forbidden"

  • I’m a maintainer of the “Best Buy Products” plugin, and I have some updates to commit. Unfortunately, the WordPress svn server isn’t letting me:

    $ svn --username pcantrell commit -m 'New features'
    Authentication realm: <http://plugins.svn.wordpress.org:80> Use your WordPress.org login
    Password for 'pcantrell':
    Sending        bbyopen.php
    svn: Commit failed (details follow):
    svn: access to '/!svn/ver/320134/best-buy-products-plugin/trunk/bbyopen.php' forbidden

    I’m listed as a plugin author on the plugin page (http://wordpress.org/extend/plugins/best-buy-products-plugin/). That means I should be able to commit, right?

    I’ve check that my username is correct, including case sensitivity. I’ve reset my password and tried with a new one. No go.

    I tried checking out a clean copy of the repo and committing changes to it. Again, same result.

    I even tried a shorter commit message (“1.2”), because some people in a forum said that had helped resolve a similar issue for them. Nothing.

    Any ideas? Is there a way I can contact the svn server’s admins? (Do you guys read this forum?) This is on a Mac running Lion.

  • The topic ‘Unable to commit to plugin svn: "forbidden"’ is closed to new replies.